[Installation] MSI GE63 RAIDER 8RE

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
Qwaser
Hankyu
Messages : 27
Inscription : jeu. 23 févr. 2017, 13:29

[Installation] MSI GE63 RAIDER 8RE

Message par Qwaser » sam. 21 mars 2020, 22:56

Bonjour à tous,

Souhaitant enfin transformer l'essai cette année, j'ai décidé d'aller au bout de mon souhait de quitter définitivement Windows pour Archlinux (que j'utilise déjà depuis 2016 sur mes serveurs) malgré mon utilisation plutôt orienté "gaming". La tentation de la simplicité de Manjaro était présente, cependant cela me laissait un goût amère de ne pas réussir à rester sur la distribution mère !

Je souhaite donc partager, à terme, mon script Bash qui automatise l'installation d'Archlinux sur un MSI GE63 RAIDER RGB 8FR. Et même si dans l'ensemble tout semble fonctionnel (pour le moment l'OS est installé sur une clé USB le temps de tout valider), il me reste quelques petits détails à régler dont je n'ai pas trouvé (ou alors pas su trouver/traduire l'anglais n'étant pas mon fort... oui je sais pour un Archlinuxien c'est fâcheux ^^) après moult recherche sur l'étendu du Web.

Le principal concerne le contrôle des ventilateurs. Sous Windows MSI nous propose Dragon Center, mais sous Linux je n'ai rien trouvé... Sauf ceci : https://github.com/YoyPa/isw, cependant j'avoue ne pas avoir trop compris son fonctionnement et quand je lis la liste des ordinateurs compatible le mien ne figure pas donc ça semble mal partit. En effet quand je joue j'aime pouvoir activer le mode "Cooler boost" qui pousse les ventilateurs au maximum ! Je préfère avoir mon CPU/GPU au plus "frais". Et la commande pwmconfig me retourne : "there are no pwm-capable sensor modules installed". Il n'existe donc aucuns moyen à l'heure actuel pour moi ? Autrement j'installe Dragon Center via Wine et ça sera réglé je pense :)

L'autre détail, bien moins important, est que lorsque j'ouvre Pamac il me dit "Aucuns paquets trouvés" dans le mode de vue "Catégories". Qu'est-ce qui peut en être la cause ? Sachant que les autres modes de vues fonctionnent, ainsi que la recherche.

En tout cas le switch de GPU demande juste de savoir mettre les bonnes variables d'environnement, on est encore loin de la simplicité du switch sous Windows, mais franchement on s'y fait ! Mes premières parties de Minecraft et Garry's Mod on été plutôt concluantes ! Je vais donc maintenant tester des jeux non compatible nativement sous Linux via Lutris.

Je vous remercie d'avance pour vos retours potentiel en espérant pouvoir migré au plus vite.

PS : J'écris ce message sous Windows donc désolé de ne pas fournir de capture d'écrans pour le moment.
Ordinateur portable :
  • MSI GE63 RAIDER RGB 8RE
  • Intel Core i7
  • 2x8 Go de RAM
  • iGPU Intel UHD 630 + GPU Nvidia GTX 1060
  • SSD PCIe NVMe 256 Go (OS) + HDD SATA 1 To (Jeux)

benjarobin
Maître du Kyudo
Messages : 15713
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Installation] MSI GE63 RAIDER 8RE

Message par benjarobin » sam. 21 mars 2020, 23:20

Bonjour,
Aucune chance que Dragon Center puisse fonctionne via Wine, en effet il y a une interaction avec le matériel : Il faut un driver
Je dirais que tu as 50% de chance que isw fonctionne pour ton portable.

Sinon tu pourra demande à rajouter le support de ton PC tel que décrit ici :
Help me support your laptop by providing following command output:
isw -cp MSI_ADDRESS_DEFAULT
via https://github.com/YoyPa/isw (open an issue).
Make sure your dump is made before altering EC with isw, you can reset your EC with a reboot or by changing power source.
Le projet à l'air actif, et plutôt bien foutu, donc tu as très forte chance d'arriver à faire ce que tu veux (Si tu comprend bien l'anglais...).
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Qwaser
Hankyu
Messages : 27
Inscription : jeu. 23 févr. 2017, 13:29

Re: [Installation] MSI GE63 RAIDER 8RE

Message par Qwaser » mar. 24 mars 2020, 16:38

Ah je vois, j'avais pas pensé à cela effectivement... Je vais me rapprocher du support du projet, cela sera plus adapté effectivement si c'est la seule piste possible.

Autrement, concernant le point Pamac qui affiche "Aucuns paquets" uniquement en mode catégorie, il s'avère que c'est suite à la dernière mise-à-jour du paquet appstream-glib il ne reste donc qu'à patienter.
Source : https://arcolinuxforum.com/viewtopic.php?f=80&t=1880

J'ai cependant un nouveau problème, j'avais le paquet optimus-manager afin de voir dans quel mode j'étais et pouvoir switcher si besoin. Au départ j'étais en mode hybrid, c'était parfais je lançais mes jeux via mon GPU NVIDIA avec les trois variables d'environnement requises (__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME="nvidia" __VK_LAYER_NV_optimus="NVIDIA_only"). Cependant suite à une mise à jour d'un paquet (le kernel de mémoire, sachant que j'étais sous la variante hardened) au redémarrage j'étais passé sur le mode "Intel" et lors du switch vers le mode Hybrid ou NVIDIA c'était un kernel panic à chaque fois...
Image

J'ai tenté une nouvelle installation propre mais en utilisant la variante classique du noyau (linux) et j'ai le même comportement. Une mise-à-jour de driver/noyau qui aurait tout "cassé" ?
Pour information voici mon script d'installation : https://framabin.org/p/?7752da60555d406 ... KOnAZ1Xso=

Quand je passerais à mon PC fixe j'ose espérer que cela sera plus simple vu que tout passe par le GPU NVIDIA, pas d'iGPU :D
Ordinateur portable :
  • MSI GE63 RAIDER RGB 8RE
  • Intel Core i7
  • 2x8 Go de RAM
  • iGPU Intel UHD 630 + GPU Nvidia GTX 1060
  • SSD PCIe NVMe 256 Go (OS) + HDD SATA 1 To (Jeux)

benjarobin
Maître du Kyudo
Messages : 15713
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Installation] MSI GE63 RAIDER 8RE

Message par benjarobin » mar. 24 mars 2020, 17:01

Si tu as installé le paquet nvidia alors que tu as un autre kernel que celui de base (version hardened), tu dois installer le paquet nvidia-dkms à la place
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Qwaser
Hankyu
Messages : 27
Inscription : jeu. 23 févr. 2017, 13:29

Re: [Installation] MSI GE63 RAIDER 8RE

Message par Qwaser » jeu. 26 mars 2020, 13:38

Oui bien entendu j'avais bien le paquet nvidia-dkms ;)

J'ai fait deux nouvelles tentatives d'installation, une avec le noyau linux-hardened + nvidia-dkms et l'autre avec le noyau classique linux + nvidia. Dans le premier cas, seul le mode "only Intel" fonctionne avec un kernel panic dès le switch en mode Nvidia only ou hybrid. Dans le second, tous les modes fonctionnent ! Je vais donc rester sur le noyau classique pour du desktop et garder le noyaux linux-hardened pour mes serveurs.

Honnêtement je suis assez content de l'avancée et j'ai bon espoir de pouvoir quitter Windows prochainement sur mon PC portable dans un premier temps :) Il ne reste qu'à régler l'histoire des ventilateurs et on sera bon, je vous partagerais l'avancée sur ce sujet et partagerais mon script d'installation complet une fois ce point validé.

Mon modèle étant proche du GE63VR, je suis tombé sur la page du Wiki suivante qui résume assez bien la situation : https://wiki.archlinux.org/index.php/MSI_GE63VR

Image Image
Ordinateur portable :
  • MSI GE63 RAIDER RGB 8RE
  • Intel Core i7
  • 2x8 Go de RAM
  • iGPU Intel UHD 630 + GPU Nvidia GTX 1060
  • SSD PCIe NVMe 256 Go (OS) + HDD SATA 1 To (Jeux)

Répondre