[zsh] Votre nouveau shell ?

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Collonges (01) France
Contact :

Message par warnaud » mer. 06 févr. 2008, 18:59

Il me manque le zsh.install :)

Autant pour moi je l'ai :)

Voilou c'est sur le repo !
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt

Avatar de l’utilisateur
bapt
Daikyu
Messages : 85
Inscription : jeu. 20 sept. 2007, 09:20
Contact :

Message par bapt » mer. 06 févr. 2008, 19:17

cool merci.

Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Collonges (01) France
Contact :

Message par warnaud » mer. 06 févr. 2008, 22:14

Ayé y'a même la version 64bit :)
Je fais aussi le pkg rxvt-unicode avec toutes les options pour pas me casser la tête :)
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt

Tristelune
Elfe
Messages : 516
Inscription : mer. 01 août 2007, 16:38

Message par Tristelune » mar. 19 févr. 2008, 22:06

Salut à tous,

suite à ce sujet je me suis à nouveau demandé si ça valait la peine d'utiliser zsh. Il s'agit d'une idée qui m'a traversé l'esprit, que j'ai balancé me disant que bash était amplement suffisant, idée reprise, re-balancé, etc. Ce coup-ci je me suis décidé à tester et je ne suis pas du tout mécontent pour l'instant!
J'ai lu les quelques trucs donnés dans ce fil de discussion,mais il y en a un qui j'aimerais bien et qui ne fonctionne pas:
yaourt -Sy[Esc-H]
Me donne le man yaourt et quand je quitte le man mon prompt est :
yaourt -Sy
Si je presse Esc-h ou Esc-H je n'arrive pas aux page de man. En fait cela correspond tout à fait au comportement de vi: en pressant h mon curseur se déplace sur la gauche et je ne peux plus rien écrire. Je suppose donc que j'active le mode navigation et h me sert à aller sur la gauche. Dois-je ajouter quelque chose dans mon .zshrc ? Comme je viens de débuter je n'ai pas grand-chose. Au cas où le voici:

Code : Tout sélectionner

#completion and prompt
autoload -U compinit promptinit
compinit
promptinit

#Default prompt
prompt redhat

#Normal aliases
alias ll='ls -l'
alias ls='ls --color=auto'

#Options
setopt correctall
Si je tape bindkey dans la console, je suppose que j'obtiens tous les raccourcis clavier. Or aucun ne correspond à Esc-h. Est-ce que quelqu'un sait ce qui ne va pas ? Merci.

Avatar de l’utilisateur
bapt
Daikyu
Messages : 85
Inscription : jeu. 20 sept. 2007, 09:20
Contact :

Message par bapt » mer. 20 févr. 2008, 10:53

Dans ton .zshrc

Code : Tout sélectionner

[ ! -x `alias run-help` ] && unalias run-help
autoload run-help # ESC-h, ESC-H, ALT-h ou ALT-H lance le man sur la commande en cours.
EDIT: ceux qui le veulent voici ma conf zsh (http://baptux.free.fr/zshconf-20080211.tar.bz2)
Attention si extraite dans votre $HOME, elle écrasera votre conf.
Attention2 : gmake et quelques script bash (dont yaourt) n'aiment pas le CDPATH).

Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Collonges (01) France
Contact :

Message par warnaud » mer. 20 févr. 2008, 19:24

bapt a écrit : EDIT: ceux qui le veulent voici ma conf zsh (http://baptux.free.fr/zshconf-20080211.tar.bz2)
Génial ! Il faut vraiment qu'on pense à faire une bibliothèque de fichiers de conf !
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt

Tristelune
Elfe
Messages : 516
Inscription : mer. 01 août 2007, 16:38

Message par Tristelune » mer. 20 févr. 2008, 22:06


Dans ton .zshrc

Code : Tout sélectionner

  [ ! -x `alias run-help` ] && unalias run-help 
 autoload run-help # ESC-h, ESC-H, ALT-h ou ALT-H lance le man sur la commande en cours.
Raaahhh, ça ne marche pas!!!!!! Il manque quelque chose. Ca ne peut pas non plus être une erreur de syntaxe puisque j'ai même essayé avec un copier-coller.
EDIT: ceux qui le veulent voici ma conf zsh (http://baptux.free.fr/zshconf-20080211.tar.bz2)
Génial, je sens que ça va être une bonne source d'inspiration.

Pour en revenir à mon problème du haut, si je prends tes fichiers de configuration, ça passe. Pourquoi est-ce que ça ne marche pas chez moi ? :mur:

J'obtiens également l'erreur suivante avec ta configuration:

Code : Tout sélectionner

[ Loading : rc/home/user/.zshenv:1: command not found: manpath
 alias complete mimes functions hash ]
Pourtant Esc-h ou alt-h fonctionnent.

Avatar de l’utilisateur
bapt
Daikyu
Messages : 85
Inscription : jeu. 20 sept. 2007, 09:20
Contact :

Message par bapt » mer. 20 févr. 2008, 23:27

Concernant le problem de manpath, c'est parce que dans le pkg man il manque un lien symbolique manpath qui point vers man.

quand le man est appelé manpath il retourne $MANPATH, j'ai pas encore fait de rapport de bug.

Concernant ton problème, c'est parce que tu utilises le bindkey vi (bindkey -v) et que Esc-h ou Alt-h sont dans le bondkey emacs (bindkey -e) --- c'est bien le seul moment ou je dois utiliser une truc qui a un rapport avec emacs --- rajoute

Code : Tout sélectionner

bindkey "^[h"   run-help
et Esc-H appellera bien run-help ou alors passe au bindkey emacs.

tu peux d'ailleurs choisir le clef que tu veux.
read -q devrait te renvoyer le code qui correspond au raccourcit clavier que tu veux faire.

Avatar de l’utilisateur
IdoMcFly
Chu Ko Nu
Messages : 436
Inscription : lun. 17 déc. 2007, 14:26

Message par IdoMcFly » jeu. 21 févr. 2008, 00:08

warnaud a écrit :
bapt a écrit : EDIT: ceux qui le veulent voici ma conf zsh (http://baptux.free.fr/zshconf-20080211.tar.bz2)
Génial ! Il faut vraiment qu'on pense à faire une bibliothèque de fichiers de conf !
ya http://www.dotfiles.com/

Tristelune
Elfe
Messages : 516
Inscription : mer. 01 août 2007, 16:38

Message par Tristelune » jeu. 21 févr. 2008, 20:10

Concernant ton problème, c'est parce que tu utilises le bindkey vi (bindkey -v) et que Esc-h ou Alt-h sont dans le bondkey emacs (bindkey -e) --- c'est bien le seul moment ou je dois utiliser une truc qui a un rapport avec emacs --- rajoute

Code : Tout sélectionner

:
  bindkey "^[h"   run-help
 
et Esc-H appellera bien run-help ou alors passe au bindkey emacs.
Ca fonctionne :D , fantastique!

Ca m'aura aussi permis de tester tes fichiers de configuration et j'ai déjà remarqué quelques petits trucs intéressants. Faudra que je creuse.

Merci pour tout!

Tristelune
Elfe
Messages : 516
Inscription : mer. 01 août 2007, 16:38

Message par Tristelune » jeu. 06 mars 2008, 09:20

J'ai de nouveau des soucis :cry: .

Mon premier est le suivant:
--------------------------------------

J'utilise le gestionnaire de fenêtre awesome. J'avais configuré le démarrage de konsole avec <Win + Return>. En mettant zsh comme shell par défaut, le raccourci ne fonctionnait plus. Après quelques recherches j'ai vu qu'il s'agissait d'un problème de PATH. Si je met zsh comme shell par défaut, mon PATH est en démarrant avec awesome:

Code : Tout sélectionner

/usr/local/bin:/usr/bin:/bin:/usr/bin:/usr/games:/bin:/bin:/sbin:/usr/sbin:/usr/local/sbin:/usr/bin:/usr/local/bin:
/usr/lib/wine/bin:/home/user:.:/bin:/bin:/sbin:/usr/sbin:/usr/local/sbin:/usr/bin:/usr/local/bin:/usr/lib/wine/bin:/home/user:.:
/bin:/bin:/sbin:/usr/sbin:/usr/local/sbin:/usr/bin:/usr/local/bin:/usr/lib/wine/bin:/home/user:.:/home/user/Eiffel61/studio/spec/linux-x86/bin
Si je démarre avec KDE c'est le même plus

Code : Tout sélectionner

/opt/kde/bin/
Si bash est mon shell par défaut, PATH contient:

Code : Tout sélectionner

/bin:/usr/bin:/sbin:/usr/sbin:/usr/X11R6/bin:/opt/bin:/opt/java/bin:/opt/java/jre/bin:/opt/kde/bin:/opt/mozilla/bin:
/opt/qt/bin:/home/user/Eiffel61/studio/spec/linux-x86/bin:/home/user/Eiffel61/library/gobo/bin:/home/user/scripts:
/home/user/Eiffel61/studio/spec/linux-x86/bin:/home/user/Eiffel61/library/gobo/bin:/home/user/scripts
Pourquoi ces valeurs changent-elles et comment avoir le même PATH que lorsque bash est par défaut ?

Deuxième problème:
----------------------------

J'ai un problème d'encodage avec zsh par défaut. J'ai lu plus haut qu'il fallait installer une version de zsh supportant l'unicode. J'ai donc installé archlinuxfr/zsh, mais ça n'a rien changé. Quand zsh est par défaut, des carrés apparaissent à la place des caractères accentués dans la console. Si bash est par défaut et que je lance zsh à partir de bash, je peux écrire les caractères accentués dans la console.
Dans les deux cas, j'ai un problème d'encodage avec mon programme de mail mutt: les caractères accentués ne sont pas reconnus. Peu importe que zsh soit par défaut ou démarré à partir de bash, ça ne change rien.
En regardant mes locales, j'ai sous bash:

Code : Tout sélectionner


$ locale

LANG=en_US.ISO-8859-1
LC_CTYPE="en_US.ISO-8859-1"
LC_NUMERIC="en_US.ISO-8859-1"
LC_TIME="en_US.ISO-8859-1"
LC_COLLATE=C
LC_MONETARY="en_US.ISO-8859-1"
LC_MESSAGES="en_US.ISO-8859-1"
LC_PAPER="en_US.ISO-8859-1"
LC_NAME="en_US.ISO-8859-1"
LC_ADDRESS="en_US.ISO-8859-1"
LC_TELEPHONE="en_US.ISO-8859-1"
LC_MEASUREMENT="en_US.ISO-8859-1"
LC_IDENTIFICATION="en_US.ISO-8859-1"
LC_ALL=
et sous zsh

Code : Tout sélectionner

$locale

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=fr_FR.UTF-8
LANGUAGE=fr_FR@euro
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=fr_FR.UTF-8
les valeurs changent et en plus j'ai une erreur. Comment récupérer ces valeurs ?

Merci!

Tristelune
Elfe
Messages : 516
Inscription : mer. 01 août 2007, 16:38

Message par Tristelune » jeu. 06 mars 2008, 19:53

J'ai trouvé pour le premier problème. Au démarrage de bash le /etc/profile est "sourcé". Zsh cherche un /etc/zprofile. Si je copie le /etc/profile dans /etc/zprofile ma variable PATH à l'air d'être en ordre. Il se peut qu'il y ait une feinte si on a à faire à un shell de connexion ou un shell interactif, mais ici ça semble fonctionner.

Reste juste le problèmes des locales.....

Tristelune
Elfe
Messages : 516
Inscription : mer. 01 août 2007, 16:38

Message par Tristelune » ven. 07 mars 2008, 11:30

Pour le problème d'encodage, juste pour tester j'ai ajouté les variables suivantes dans mon /etc/zshenv

Code : Tout sélectionner

export LANG=en_US.ISO-8859-1
export LC_CTYPE="en_US.ISO-8859-1"
export LC_NUMERIC="en_US.ISO-8859-1"
export LC_TIME="en_US.ISO-8859-1"
export LC_COLLATE=C
export LC_MONETARY="en_US.ISO-8859-1"
export LC_MESSAGES="en_US.ISO-8859-1"
export LC_PAPER="en_US.ISO-8859-1"
export LC_NAME="en_US.ISO-8859-1"
export LC_ADDRESS="en_US.ISO-8859-1"
export LC_TELEPHONE="en_US.ISO-8859-1"
export LC_MEASUREMENT="en_US.ISO-8859-1"
export LC_IDENTIFICATION="en_US.ISO-8859-1"
export LC_ALL= 
Et ensuite c'était bon pour l'encodage. Mais comme je n'ai pas ça dans mon .bashrc, je pense qu'on peut résoudre le problème autrement. J'ai donc effacé ces variables de mon /etc/zshenv et..... mon encodage après un redémarrage sous zsh n'avait pas bougé :shock:

Maintenant sans rien ça fonctionne. J'ai loupé un épisode. Ma seule idée est qu'en ajoutant ces variables, un fichier a été modifié ou créé. Quelqu'un aurait-il une idée duquel ?

Avatar de l’utilisateur
Tebo
Chu Ko Nu
Messages : 368
Inscription : sam. 17 mars 2007, 23:24

Message par Tebo » sam. 19 avr. 2008, 11:05

http://asyd.net/talks/intro-zsh.avi

[/prosel]

ps: je croit que le paquet du dépôt n'est plus nécessaire:

less /var/abs/extra/zsh/PKGBUILD:
--enable-multibyte
--enable-zsh-mem
--with-tcsetpgrp
..

:)
Dernière modification par Tebo le sam. 19 avr. 2008, 11:14, modifié 1 fois.

Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Collonges (01) France
Contact :

Message par warnaud » sam. 19 avr. 2008, 11:11

Elle est classe cette vidéo :D
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt

Avatar de l’utilisateur
wain
Maître du Kyudo
Messages : 1854
Inscription : ven. 11 août 2006, 19:15
Localisation : Nancy (54)
Contact :

Message par wain » sam. 19 avr. 2008, 12:41

ouep merci Tebo pour cette video. C'est exactement ce qui me manquait. Maintenant je suis définitivement décidé pour le choix de mon shell :D

Edit: je vais éviter le troll mais vous aurez compris que je reste fidèle à ce bon vieux bash, même si je reconnaîs d'énormes qualités à zsh (même plus de qualités peut-être que bash)
Dernière modification par wain le sam. 19 avr. 2008, 15:26, modifié 1 fois.

Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Collonges (01) France
Contact :

Message par warnaud » sam. 19 avr. 2008, 15:01

Faudrait des gens motiver pour réécrire les scripts d'init en zsh :p
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt

Répondre