[Clavier] Bonne disposition (Résolu)

Reconnaissance et configuration du matériel / kernel linux
Avatar de l’utilisateur
Joan31
Chu Ko Nu
Messages : 350
Inscription : mer. 27 mai 2015, 09:37

[Clavier] Bonne disposition (Résolu)

Message par Joan31 »

Bonjour,

J'ai pour habitude de configurer de cette façon mon clavier :

Code : Tout sélectionner

localectl set-x11-keymap fr pc105 latin9
Cependant, la correspondance des touches n'est pas correct à 100%.

Exemple, la touche [²] me renvois un * sur le prompt, traitement de textes, etc....

Je pense que c'est la variante qui n'est pas bonne. Du coup j'aimerai bien savoir ce que vous mettez comme configuration pour que le clavier "match" correctement.

Photo de la disposition du clavier :

Image

Merci d'avance.
Dernière modification par Joan31 le lun. 02 nov. 2020, 20:42, modifié 1 fois.
Arch Linux | KDE Plasma 5
AMD Ryzen 2700X @4.3Ghz | AMD Radeon RX 5700 XT
▹ 16Go DDR4 @3200Mhz | NVMe 1To + 512Go

Joan31
jimarch
archer de cavalerie
Messages : 166
Inscription : mer. 26 déc. 2012, 20:38
Localisation : La Roche sur Yon - 85000

Re: [Clavier] Bonne disposition

Message par jimarch »

Personnellement, j'ai appliqué la proposition fournie par Benjarobin
dans le fil de discussion suivant :
viewtopic.php?f=1&t=19542&p=162657&hili ... in#p162657
localectl --no-convert set-x11-keymap fr "" latin9
Ca marche très bien chez moi, mais c'est pas forcément ce que tu cherches !
Fixe : AMD Ryzen 5 2600X Six-Core Processor | 15,6 Gio de mémoire vive | GeForce GTX 1650 SUPER/PCIe/SSE2
Portable : Plasma - Kde | Notebook Clevo W740SU | Plateforme Intel Haswell avec Intel Core i7-4750HQ | Intel Iris Pro graphics 5200
Sauvegardes quotidiennes de mes système et données par BORG
benjarobin
Maître du Kyudo
Messages : 16075
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Clavier] Bonne disposition

Message par benjarobin »

latin9 ne devrait plus être utilisé (enfin plus la recommandation depuis des années), voir viewtopic.php?p=174136#p174136
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
Joan31
Chu Ko Nu
Messages : 350
Inscription : mer. 27 mai 2015, 09:37

Re: [Clavier] Bonne disposition

Message par Joan31 »

Merci pour ta réponse.

Du coup je testerai cela ce soir :

Code : Tout sélectionner

localectl set-x11-keymap --no-convert fr pc105 oss_latin9 terminate:ctrl_alt_bksp
Par contre, je ne comprend pas l'utilisation du --no-convert, dans le manuel il est expliqué ceci :

Code : Tout sélectionner

--no-convert
         If set-keymap or set-x11-keymap is invoked and this option is
         passed, then the keymap will not be converted from the console to
         X11, or X11 to console, respectively.
Quel est l'effet de cette option entre la console et X11 ?

D'ailleurs pour le tyy, mon /etc/vconsole.conf ressemble à cela, dois je aussi le modifier ?

Code : Tout sélectionner

KEYMAP=fr
FONT=lat9w-16
Merci encore.
Dernière modification par Joan31 le lun. 02 nov. 2020, 17:29, modifié 1 fois.
Arch Linux | KDE Plasma 5
AMD Ryzen 2700X @4.3Ghz | AMD Radeon RX 5700 XT
▹ 16Go DDR4 @3200Mhz | NVMe 1To + 512Go

Joan31
benjarobin
Maître du Kyudo
Messages : 16075
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Clavier] Bonne disposition

Message par benjarobin »

Si tu ne spécifies pas "--no-convert" alors il essaye de mettre à jour /etc/vonconsole.conf avec une locale "proche". Il n'y a pas de compatibilité 1 vers 1 entre les locales X11 et tty.
Je préfère faire le localectl qui va bien avec aussi "--no-convert" pour mettre à jour comme je veux (et non automatiquement) le /etc/vonconsole.conf
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
Joan31
Chu Ko Nu
Messages : 350
Inscription : mer. 27 mai 2015, 09:37

Re: [Clavier] Bonne disposition

Message par Joan31 »

Super merci beaucoup. Bien compris.
Cela fonctionne correctement désormais.
Concernant l'option "--no-convert" je la garde bien au chaud.
Je préfère, tout comme toi, bien distinguer le tty et X11. Comme ça pas d’ambiguïté, pas de surprise.

Je passe en résolu.
Arch Linux | KDE Plasma 5
AMD Ryzen 2700X @4.3Ghz | AMD Radeon RX 5700 XT
▹ 16Go DDR4 @3200Mhz | NVMe 1To + 512Go

Joan31
Répondre