[lightdm] Mauvaise disposition de clavier sur l'écran de connexion (Résolu)

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
Avatar de l’utilisateur
PowaBanga
archer
Messages : 122
Inscription : mar. 12 sept. 2017, 21:15

[lightdm] Mauvaise disposition de clavier sur l'écran de connexion (Résolu)

Message par PowaBanga »

Salut à tous !
J'ai donc finalement installé lightdm, et cela fonctionne à la perfection, à un tout petit détail près.

Mes terminaux TTY et mon environnement mate ont bien la bonne disposition clavier, mais. Lors du démarrage, ou quand je ferme ma session utilisateur, l'agencement du clavier est en qwerty !

J'ai cherché, mais à l'évidence un détail m'échappe, je me doute bien qu'il s'agit d'un truc tout bête, mais si quelqu'un pouvait m'aiguiller pour trouver la réponse, je lui en serait vraiment reconnaissant :roll:
Dernière modification par PowaBanga le mer. 10 juin 2020, 10:06, modifié 2 fois.
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [lightdm] Mauvaise disposition de clavier sur l'écran de connexion

Message par benjarobin »

Code : Tout sélectionner

sudo localectl set-x11-keymap --no-convert fr pc105 oss_latin9 terminate:ctrl_alt_bksp
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
PowaBanga
archer
Messages : 122
Inscription : mar. 12 sept. 2017, 21:15

Re: [lightdm] Mauvaise disposition de clavier sur l'écran de connexion

Message par PowaBanga »

ha désolé, j'ai été trop vite en écrivant ce message tout à l'heure. J'aurrais dû donner plus d'informations !

D'abord je dispose d'un clavier belge : fr_BE.UTF8 be-latin1

J'avais déjà édité ce fichier manuellement en suiviant les indications du wiki
mais j'ai dû louper un truc... :/

Code : Tout sélectionner

[root@ArchiBM user]# cat /etc/X11/xorg.conf.d/00-keyboard.conf
Section "InputClass"
	Identifier	"Keyboard Layout"
	MatchIsKeyboard	"yes"
	Option		"XkbLayout"	"be"
	Option		"XkbVariant"	"latin1"
EndSection
Suite de ton message, voici donc ce que j'ai essayé :

Code : Tout sélectionner

[root@ArchiBM user]# setxkbmap -print -verbose 10
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     be
Trying to build keymap using the following components:
keycodes:   evdev+aliases(azerty
types:      complete
compat:     complete
symbols:    pc+be+inet(evdev)
geometry:   pc(pc105)
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(azerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+be+inet(evdev)"	};
	xkb_geometry  { include "pc(pc105)"	};
};

Code : Tout sélectionner

[root@ArchiBM user]# localectl set-x11-keymap --no-convert be pc105 oss_latin1 terminate:ctrl_alt_bksp
Failed to set keymap: Specified keymap cannot be compiled, refusing as invalid.
Voili voilou, encore une fois, merci infiniment pour ton aide benjarobin !
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [lightdm] Mauvaise disposition de clavier sur l'écran de connexion (en cours...)

Message par benjarobin »

Il n'existe pas de variant "latin1" pour un layout "be" pour X11.
Mais en effet pour les tty tu dois utiliser le layout be-latin1, mais c'est quelque chose d'indépendant (X11 est totalement indépendant de /etc/vconsole.conf)

Pour le savoir il faut lire /usr/share/X11/xkb/rules/xorg.lst
Tu n'as le choix en variant que ceci :

Code : Tout sélectionner

  oss             be: Belgian (alt.)
  oss_latin9      be: Belgian (alt., Latin-9 only)
  oss_sundeadkeys be: Belgian (alt., with Sun dead keys)
  iso-alternate   be: Belgian (alt. ISO)
  nodeadkeys      be: Belgian (no dead keys)
  sundeadkeys     be: Belgian (with Sun dead keys)
  wang            be: Belgian (Wang 724 AZERTY)
Bref pour toi tu veux sûrement

Code : Tout sélectionner

sudo localectl set-x11-keymap --no-convert be pc105 oss_latin9 terminate:ctrl_alt_bksp
Attention de ne pas mélanger locale (fr_BE.UTF8) et layout du clavier, ce sont 2 choses sans aucun lien.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
PowaBanga
archer
Messages : 122
Inscription : mar. 12 sept. 2017, 21:15

Re: [lightdm] Mauvaise disposition de clavier sur l'écran de connexion (Résolu)

Message par PowaBanga »

Merci pour ta réponse et ces éclaircissement benjarobin.
Cela à réglé le souci
Répondre