[kernel/driver nvidia] nvidia-driver et kernel26 ? (résolu)

Reconnaissance et configuration du matériel / kernel linux
Avatar de l’utilisateur
PillOow
Daikyu
Messages : 68
Inscription : mer. 18 juin 2008, 22:07

[kernel/driver nvidia] nvidia-driver et kernel26 ? (résolu)

Message par PillOow »

Bonjour à tous

Je viens de compiler le noyau 2.6.28 en vanilla tout à l'air de fonctionner excepté le driver nvidia bien sûr. Donc il faudrait que j'installe le paquet nvidia-driver se trouvant sur le dépot archlinuxfr mais celui-ci sera-t-il toujours compatible avec le kernel générique ? Est-ce qu'il y a conflit entre les deux drivers (nvidia-driver et nvidia) ? C'est à dire si j'en installe un l'autre se barre. Parce que pour l'instant je vais surtout expérimenter un peu le noyau compilé alors j'aimerais garder à mes cotés le kernel de base. Quelles solutions s'offrent à moi ?

Sinon j'ai l'intention de patcher ce kernel, ce serait surtout pour voir si j'ai une amélioration du temps de rendu sous Blender. Je pense pas mais bon. Du coup j'ai deux trois question:

-Avez-vous déjà entendu parler d'un patch permettant d'améliorer significativement du temps de rendu ( ce qui me semble gros ) ou sinon qui est plus apte au calcul lourd ( mais là on est plus sur du patch server ) ?

-Y a-t-il un patch utilisant un scheduler différent que ceux des vanilla ? Si telle est le cas, y en a-t-il un adapté aux processeurs à quatres coeurs ?

-J'ai vu que les patchs beyond et emission n'étaient plus dispo par la méthode ABS, pkgbuild et toussa, trop vieux surement. Quelles sont les patchs compatibles gensplash/fbsplash ?

-C'est quoi la différence entre gensplash et fbsplash d'ailleurs ?

Et puis j'ai un truc bizarre, lorsque je tente de patcher mon kernel avec le genpatches vient le moment où l'on me demande si je veux compiler une image fbsplash parce que le patch genpatches permet au kernel de supporter le démarrage graphique. Je met non et à la question suivante, à savoir " Voulez-vous afficher un simple logo Archlinux à la place de fbsplash ?", entre parenthèses l'on me dit que mon kernel ne supporte pas fbsplash. Ces messages sont juste des suggestions ou de vraies remarques ? Parce que j'avais exactement la même chose avec vanilla.

Voilà je cherche, merci d'avance. :wink:

PS: Pour les questions concernant les patches, si vous préferez je peux faire un topic à part, mais j'ai pensé que c'était mieux ainsi.

EDIT: Je me répond à moi même:

-Oui, il y a conflit avec nvidia-driver et nvidia. C'est soit l'un soit l'autre. pouète
Dernière modification par PillOow le mer. 14 janv. 2009, 23:14, modifié 1 fois.
Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Rolle (CH)
Contact :

Message par warnaud »

nvidia-driver est compatible avec le noyau fournit par archlinux (moyennant une recompilation automatique ;) )
Pour gensplash / fbsplash je te renvois à google, perso j'en ai aucune idée, je trouve d'ailleurs dommage qu'il y'ait pas un de ces deux patchs dans le kernel de base vu les autres patchs :D mais bon ça boot tellement vite arch :pompom:
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt
Thom1
Daikyu
Messages : 57
Inscription : mer. 12 nov. 2008, 17:08
Contact :

Message par Thom1 »

Salut,

Pour compiler ton pilote nvidia, il te faut le PKGBUILD du pilote et le modifier pour l'adapter à ton kernel : changer le numéro de version et enlever la dépendance à kernel26. Et ensuite, un petit makepkg pour faire un beau paquet.
Avatar de l’utilisateur
gyo
Maître du Kyudo
Messages : 1049
Inscription : jeu. 19 avr. 2007, 10:40
Localisation : Nantes (44)
Contact :

Message par gyo »

Thom1 a écrit :Salut,

Pour compiler ton pilote nvidia, il te faut le PKGBUILD du pilote et le modifier pour l'adapter à ton kernel : changer le numéro de version et enlever la dépendance à kernel26. Et ensuite, un petit makepkg pour faire un beau paquet.
Même pas besoin, Warnaud parlait de nvidia-driver qui est un paquet provenant du dépôt [archlinuxfr]. Ce paquet, à l’installation, compile automatiquement le pilote à partir des sources (et donc en fonction du noyau tournant sur le système). nvidia-driver est compatible tout noyaux (non vanilla notamment)

@PillOow : sinon tu avais la possibilité d’installer le noyau 2.6.28 avec le paquet testing…
Et oui en fait nvidia-driver fournit un pilote nvidia à l’instar du paquet nvidia, c’est pourquoi c’est en conflit, et il le remplace complètement.
commentaire rédigé à l’aide d’un clavier ergonomique bépo
KISS MY ARCH
Avatar de l’utilisateur
PillOow
Daikyu
Messages : 68
Inscription : mer. 18 juin 2008, 22:07

Message par PillOow »

Merci pour vos réponses !
@PillOow : sinon tu avais la possibilité d’installer le noyau 2.6.28 avec le paquet testing…
Ce que j'ai fait ! Mais l'interet de compiler mon propre kernel est d'améliorer les performances. Ou du moins, de voir si j'améliore significativement mes performances. J'ai constaté que je boot plus vite sur mon kernel optimisé c'est déjà ça. :)

Bon par contre impossible d'installer nvidia-driver lorsque je tourne sous mon kernel optimisé. Enfin ce n'est pas impossible, mais il souhaite m'installer en dépendance plus de 600 Mo de paquets. Cela s'explique par le fait que j'ai installé le script pacman-cage et qu'il ne semble pas fonctionner sous le noyau compilé. Donc pacman n'a accès qu'a une base de donnée obsolète à ce moment là. De quels modules à besoin pacman-cage pour fonctionner ? Parce que le module "loop" est bien chargé mais est-ce que cela suffit au support des "loopback devices" ? J'ai du oublier de compiler quelque chose.

EDIT: C'est bon j'ai pigé, j'ai oublié de compiler le support pour l'ext2 dont pacman-cage à besoin. Je me lance et je vous tiens au courant pour la suite.
Avatar de l’utilisateur
PillOow
Daikyu
Messages : 68
Inscription : mer. 18 juin 2008, 22:07

Message par PillOow »

Bonsoir, je n'arrive toujours pas à faire marcher ma carte avec mon kernel. Une erreur à l'install. Je précise que X est inactif lorsque je fais la manip.

Code : Tout sélectionner

[pilloow@ArchLinux:~]$yaourt -S archlinuxfr/nvidia-driver
Mot de passe : 
Résolution des dépendances...
Recherche des conflits possibles entre paquets...
:: nvidia-driver est en conflit avec nvidia. Supprimer nvidia? [O/n] o
:: nvidia-driver est en conflit avec nvidia-utils. Supprimer nvidia-utils? [O/n] o

Suppression (2): nvidia-180.22-1  nvidia-utils-180.22-1  

Taille totale des paquets (suppression):   34,16 Mo

Cibles (1): nvidia-driver-173.14.12-1  

Taille totale des paquets (téléchargement):   0,00 Mo
Taille totale des paquets (installation):   33,13 Mo

Procéder à l'installation? [O/n] o
Analyse de l'intégrité des paquets...
:: Updating symlinks to use xorg-server libwfb
(1/1) Analyse des conflits entre fichiers           [###################################################################################################] 100%
(1/1) Installation nvidia-driver                    [###################################################################################################] 100%
IMPORTANT
==> In order to use the software, you have to agree to NVIDIA's license located in 
==> /usr/share/doc/NVIDIA_GLX-1.0/LICENSE else please remove this package
Installation starts now ...
INSTALLATION FAILED!
==> You have to shutdown Xserver to finish installation! You have to rerun 'pacman -S nvidia-driver'
==> Other installation errors can be found at: /var/log/nvidia-installer.log

Please add 'nvidia' to daemon array in /etc/rc.conf file
rm: ne peut enlever `/usr/lib/libGL.la': Aucun fichier ou dossier de ce type
FATAL: Module nvidia not found.
Et le contenu de /var/log/nvidia-installer.log :

Code : Tout sélectionner

[pilloow@ArchLinux:~]$cat /var/log/nvidia-installer.log 
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Tue Jan 13 00:52:56 2009
installer version: 1.0.7

option status:
  license pre-accepted    : true
  update                  : false
  force update            : false
  expert                  : false
  uninstall               : false
  driver info             : false
  precompiled interfaces  : false
  no ncurses color        : false
  query latest version    : false
  OpenGL header files     : false
  no questions            : true
  silent                  : false
  no recursion            : false
  no backup               : false
  kernel module only      : false
  sanity                  : false
  add this kernel         : false
  no runlevel check       : false
  no network              : true
  no ABI note             : false
  no RPMs                 : false
  no kernel module        : false
  force SELinux           : default
  no X server check       : false
  no cc version check     : false
  force tls               : (not specified)
  X install prefix        : (not specified)
  X library install path  : (not specified)
  X module install path   : (not specified)
  OpenGL install prefix   : (not specified)
  OpenGL install libdir   : (not specified)
  utility install prefix  : (not specified)
  utility install libdir  : (not specified)
  doc install prefix      : (not specified)
  kernel name             : (not specified)
  kernel include path     : (not specified)
  kernel source path      : (not specified)
  kernel output path      : (not specified)
  kernel install path     : (not specified)
  proc mount point        : /proc
  ui                      : none
  tmpdir                  : /tmp
  ftp mirror              : ftp://download.nvidia.com
  RPM file list           : (not specified)

Using built-in stream user interface
-> License accepted by command line option.
-> Installing NVIDIA driver version 173.14.12.
-> Not probing for precompiled kernel interfaces.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> Kernel source path: '/lib/modules/2.6.28-04012009-2/source'
-> Kernel output path: '/lib/modules/2.6.28-04012009-2/build'
ERROR: If you are using a Linux 2.4 kernel, please make sure
       you either have configured kernel sources matching your
       kernel or the correct set of kernel headers installed
       on your system.
       
       If you are using a Linux 2.6 kernel, please make sure
       you have configured kernel sources matching your kernel
       installed on your system. If you specified a separate
       output directory using either the "KBUILD_OUTPUT" or
       the "O" KBUILD parameter, make sure to specify this
       directory with the SYSOUT environment variable or with
       the equivalent nvidia-installer command line option.
       
       Depending on where and how the kernel sources (or the
       kernel headers) were installed, you may need to specify
       their location with the SYSSRC environment variable or
       the equivalent nvidia-installer command line option.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.
Apparemment, j'aurais des paramètres à changer dans un fichier de conf mais où est-il ? Et une aussi une variable d'environnement à modifier mais je ne sais guère quoi mettre. En gros je comprend rien :mrgreen:

Bon sinon il me reste cette méthode >> http://wiki.archlinux.org/index.php/NVI ... tom_kernel

Mais premier problème, je n'ai aucun /var/abs/extra et par conséquent pas de /var/abs/extra/nvidia << Ouah la logique qui tue !

Croyez vous que cela ait un rapport avec l'utilisation de pacman-cage ?

Vala c'est tout, en attendant de trouver une solution je vais utiliser le pilote "nouveau" sur ce kernel pour voir.

Merci bien !
Thom1
Daikyu
Messages : 57
Inscription : mer. 12 nov. 2008, 17:08
Contact :

Message par Thom1 »

Pour avoir l'arbre abs, il faut lancer la commande "abs" (en root).
http://wiki.archlinux.fr/howto:archlinux:abs
Avatar de l’utilisateur
PillOow
Daikyu
Messages : 68
Inscription : mer. 18 juin 2008, 22:07

Message par PillOow »

Ah ouais en effet tout s'explique ! :fou:

Merci beaucoup je teste ça.
Avatar de l’utilisateur
PillOow
Daikyu
Messages : 68
Inscription : mer. 18 juin 2008, 22:07

Message par PillOow »

C'est bon !

Apparemment, incompatibilité des versions 173.xx.xx avec le kernel 2.6.28. J'me suis fait mon propre paquet utilisant le tuto sur le wiki anglophone mais en utilisant le PKGBUILD de nvidia présent dans testing ! :)
Répondre