Page 1 sur 1

[Archlinux32] partitionnement - Vieilles partitions et problème avec sda

Publié : ven. 20 avr. 2018, 13:59
par Matows
Bonjour !
Bon petite mise au point :
- je suis tout nouveau sous arch.
- J'utilise une vieille machine sur laquelle je compte installer archlinux 32bit (celle soutenu par la communauté).
- Je voudrais utiliser le script Archlinux Ultimate Installator (aui) pour ma première fois, mais j'ai pas de problème à faire sans (j'ai essayé de partitionner avec fdisk en suivant ce tutoriel.

J'avais avant une installation ubuntu-server que j'avais du installer avec LVM (ne sachant pas trop ce que c'était à l'époque) ce qui est complètement innutile pour mon usage. Je me retrouve donc avec des partitions "parasites" : /dev/mapper/ubuntu--server--vg-root et /dev/mapper/ubuntu--server--vg-swap_1, qui me prenne tout de même 74 GiB (je ne connais d’ailleurs pas ma capacité initial :oops:).

Je voudrais donc les supprimés, voir même effacer tout le disque dur.

J'ai un autre problème : une fois le partitionnement de sda fait (en suivant le turoriel), j'ai essayé de formater sda3 en ext4 et j'ai reçu une erreur comme quoi la partition n'existait pas (alors que j'ai fait sda1>boot, sda2>swap et sda3>root). fdisk -l renvoi bien le partitionnement sda1/sda2/sda3.

Cordialement,
M'.

Re: [Partitionnement] Vieilles partitions et problème avec sda

Publié : ven. 20 avr. 2018, 14:10
par averellb
Bonjour,

Une remarque préliminaire, il est vivement conseillé de préférer le wiki à toute autre source de documentation sur Archlinux. Un tuto de 2015 a peu de chances d'être encore valable 3 ans après. Pour le partitionnement passe encore, mais d’une manière générale c’est à éviter.

Commençons par la fin : peux tu donner la sortie exacte de mkfs pour comprendre ce qui fait échouer le formatage ? Car en effet si fdisk dit que la partition existe on ne voit pas pourquoi elle n'existerait pas.

Quant à tes anciennes partitions lvm, si tu as re-partitionné comme tu l'indiques elles ont dû disparaître toutes seules, sinon je veux bien voir la sortie complète de fdisk -l /dev/sda.

Re: [Partitionnement] Vieilles partitions et problème avec sda

Publié : ven. 20 avr. 2018, 14:49
par Matows
Bon ba c'est bon, je me sent déjà bête : entre temps j'ai redémarrer le pc (toujours sur la live USB) et ce qu'il m'affiche est correct... :oops:
http://paste.ubuntu.com/p/BdFtRnhk5R/

Donc normalement ça devrait être tout bon...
Je vous dit si j'ai un vrai problème durant l'installation.

Et merci tu conseil pour archlinux et la doc :D

M'

Re: [Partitionnement] Vieilles partitions et problème avec sda

Publié : ven. 20 avr. 2018, 14:58
par Shade
Bonjour,

T'es sur que t'as bien suivi cette page https://wiki.archlinux.fr/Installation# ... partitions
100Mo ça me parait un peu juste

Re: [Partitionnement] Vieilles partitions et problème avec sda

Publié : ven. 20 avr. 2018, 15:18
par Matows
Shade a écrit :
ven. 20 avr. 2018, 14:58
Bonjour,

T'es sur que t'as bien suivi cette page https://wiki.archlinux.fr/Installation# ... partitions
100Mo ça me parait un peu juste
Et bien j'avais regardé l'autre lien justement. Mais je referai avec 300M

Re: [Partitionnement] Vieilles partitions et problème avec sda

Publié : ven. 20 avr. 2018, 16:27
par waitnsea
Matows a écrit :
ven. 20 avr. 2018, 13:59
- J'utilise une vieille machine sur laquelle je compte installer archlinux 32bit (celle soutenu par la communauté).
Bonjour,
L'Architecture 32b n'est plus supportée officiellement, vois cette annonce et le lien pour la branche communautaire 32b.
Quant à un tutoriel de 2014 ! tant de choses ont changé depuis, va sur le site de la nouvelle branche 32b...

Re: [Partitionnement] Vieilles partitions et problème avec sda

Publié : ven. 20 avr. 2018, 17:16
par Matows
waitnsea a écrit :
ven. 20 avr. 2018, 16:27
Matows a écrit :
ven. 20 avr. 2018, 13:59
- J'utilise une vieille machine sur laquelle je compte installer archlinux 32bit (celle soutenu par la communauté).
Bonjour,
L'Architecture 32b n'est plus supportée officiellement, vois cette annonce et le lien pour la branche communautaire 32b.
Quant à un tutoriel de 2014 ! tant de choses ont changé depuis, va sur le site de la nouvelle branche 32b...
J'ai justement dit que j'utilisais cette version (https://archlinux32.org/).
Il y a tant de chose que ça qui on changer pour le partitionnement ?

Re: [Partitionnement] Vieilles partitions et problème avec sda

Publié : ven. 20 avr. 2018, 18:31
par waitnsea
Le partitionnement a un peu changé : il n'y a vraiment aucun intérêt à une partition /boot séparée, (que des ennuis en fait)
Puis il y a la suite du tuto, au rayon fstab déjà: utiliser les UUID donc genstab -U et non -L , etc...
Dis-nous la taille de ton HDD et ce que tu envisages pour tes partitions 2 (swap et / ) ou 3 (/home séparé en +), et leur taille

Re: [Partitionnement] Vieilles partitions et problème avec sda

Publié : ven. 20 avr. 2018, 18:46
par Matows
waitnsea a écrit :
ven. 20 avr. 2018, 18:31
Le partitionnement a un peu changé : il n'y a vraiment aucun intérêt à une partition /boot séparée, (que des ennuis en fait)
Puis il y a la suite du tuto, au rayon fstab déjà: utiliser les UUID donc genstab -U et non -L , etc...
Dis-nous la taille de ton HDD et ce que tu envisages pour tes partitions 2 (swap et / ) ou 3 (/home séparé en +), et leur taille
Étant donné que je suis débutant et que c'est une machine pour testé, j'ai opté pour un partitionnement simple (sda1 pour /, sda2 pour swap (2Go)). J'ai alloué tout le reste du disque à / (72.5G).

Re: [Partitionnement] Vieilles partitions et problème avec sda

Publié : ven. 20 avr. 2018, 19:17
par waitnsea
Sur un petit HDD c'est ce qu'il y a de mieux en plus.

Donne, stp le retour de

Code : Tout sélectionner

# parted -l /dev/sda

Re: [Partitionnement] Vieilles partitions et problème avec sda

Publié : sam. 21 avr. 2018, 09:30
par FoolEcho
Matows a écrit :
ven. 20 avr. 2018, 17:16
J'ai justement dit que j'utilisais cette version (https://archlinux32.org/).
En passant, je demande à nos admins de rajouter une section pour le 32 bits niveau forum (j'ai modifié ton titre en conséquence aussi), qu'on gagne en lisibilité. :moderationok:

Re: [Partitionnement] Vieilles partitions et problème avec sda

Publié : sam. 21 avr. 2018, 14:42
par Matows
waitnsea a écrit :
ven. 20 avr. 2018, 19:17
Sur un petit HDD c'est ce qu'il y a de mieux en plus.

Donne, stp le retour de

Code : Tout sélectionner

# parted -l /dev/sda
Le disque fait 80Go (model : ATA Maxtor 6L080M0)
FoolEcho a écrit :
sam. 21 avr. 2018, 09:30
Matows a écrit :
ven. 20 avr. 2018, 17:16
J'ai justement dit que j'utilisais cette version (https://archlinux32.org/).
En passant, je demande à nos admins de rajouter une section pour le 32 bits niveau forum (j'ai modifié ton titre en conséquence aussi), qu'on gagne en lisibilité. :moderationok:
Merci :)

Une fois l'installation faite, j'ai utilisé lilo de AUI pour installer l'environnement graphique, serveur X etc. Mais l'affichage plante en démarrant le système et je ne peux pas accéder à la ligne de commande. Je peux me connecter au système via la live USB et arch-chroot mais je ne sais pas comment désactiver le démarrage automatique du serveur X.
Une idée ?

Re: [Partitionnement] Vieilles partitions et problème avec sda

Publié : sam. 21 avr. 2018, 16:21
par waitnsea
Matows a écrit :
sam. 21 avr. 2018, 14:42
waitnsea a écrit :
ven. 20 avr. 2018, 19:17
Donne, stp le retour de

Code : Tout sélectionner

# parted -l /dev/sda
Une idée ?
Pourquoi ne donnes-tu pas les retours de commande quand on te les demande ? Tu reprends le cd-live d'installation, tout simplement...

Re: [Partitionnement] Vieilles partitions et problème avec sda

Publié : dim. 22 avr. 2018, 09:17
par FoolEcho
Matows a écrit :
sam. 21 avr. 2018, 14:42
Une fois l'installation faite, j'ai utilisé lilo de AUI pour installer l'environnement graphique, serveur X etc. Mais l'affichage plante en démarrant le système et je ne peux pas accéder à la ligne de commande. Je peux me connecter au système via la live USB et arch-chroot mais je ne sais pas comment désactiver le démarrage automatique du serveur X.
Une idée ?
De la même façon qu'il a été activé... Faut désactiver le service systemd qui va bien, typiquement ton gestionnaire de connexion, gdm ou autre ( https://wiki.archlinux.fr/Systemd#Services ) ou modifier la ligne du kernel au moment du démarrage pour passer en niveau 3 ( https://wiki.archlinux.fr/Systemd#Target ; https://wiki.archlinux.fr/Syslinux#Options_temporaires ).

Re: [Partitionnement] Vieilles partitions et problème avec sda

Publié : dim. 22 avr. 2018, 18:30
par Matows
waitnsea a écrit :
sam. 21 avr. 2018, 16:21
Matows a écrit :
sam. 21 avr. 2018, 14:42
waitnsea a écrit :
ven. 20 avr. 2018, 19:17
Donne, stp le retour de

Code : Tout sélectionner

# parted -l /dev/sda
Une idée ?
Pourquoi ne donnes-tu pas les retours de commande quand on te les demande ? Tu reprends le cd-live d'installation, tout simplement...
Parce que je n'avais pas assez de temps pour upload ça via curl sur paste.ubuntu.com (je sais pas si il y a un équivalent pour arch) et copier à la main le code ici. Mais maintenant que je peux, le voici : http://paste.ubuntu.com/p/myPVXHsj9c/

Et merci FoolEcho cela fonctionne :)

Re: [Archlinux32] partitionnement - Vieilles partitions et problème avec sda

Publié : lun. 11 juin 2018, 17:49
par Piczel
Salut, pour paste du code, j'utilise ptpb qui a l'avantage d'être ultra facilement utilisable depuis la ligne de commande.

J'utilise cette fonction, via un simple appel de pbx <commande>

Code : Tout sélectionner

pbx () {
	curl -sF "c=@${1:--}" -w "%{redirect_url}" 'https://ptpb.pw/?r=1' -o /dev/stderr | xsel -l /dev/null -b
}
En plus, elle te met l'URL généré dans ton clipboard directement, m'enfin, un must-have