[AUR] impossible d'installer cloop. (contourné)

Mise à jour / Création /debug de paquetages
Répondre
Avatar de l’utilisateur
Anghirrim
Elfe
Messages : 692
Inscription : mar. 28 févr. 2012, 11:09
Localisation : Loire-Atlantique

[AUR] impossible d'installer cloop. (contourné)

Message par Anghirrim » jeu. 13 sept. 2012, 16:31

Hello,

Pour certaines raisons obscures, je veux extraire le fichier compressé KNOPPIX présent dans l'iso de Knoppix (/KNOPPIX/KNOPPIX).

Cependant, pour cela il me faut le module cloop présent sur AUR.

Seulement, j'ai un souci lors de la construction du paquet:

Code : Tout sélectionner

Building for Kernel Patchlevel 6
make modules -C /usr/src/linux-3.4.7-1-ARCH M=/tmp/yaourt-tmp-root/aur-cloop/src/cloop-2.639
make[1] : on entre dans le répertoire « /usr/src/linux-3.4.7-1-ARCH »
make[1]: *** Aucune règle pour fabriquer la cible « modules ». Arrêt.
make[1] : on quitte le répertoire « /usr/src/linux-3.4.7-1-ARCH »
make: *** [cloop.ko] Erreur 2
Le PKGBUILD est bien celui qui est censé fonctionner (cf la page AUR pour cloop).

Que faire pour installer cloop? A moins que vous n'ayez une autre idée pour extraire KNOPPIX?
Dernière modification par Anghirrim le sam. 22 sept. 2012, 11:45, modifié 1 fois.
Tour Intel© Core™ i5-4670, Arch Linux Cinnamon + Windows 10
Asus X53S, Linux Mint Tricia 19.3 Cinnamon

benjarobin
Maître du Kyudo
Messages : 15903
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [AUR] impossible d'installer cloop.

Message par benjarobin » jeu. 13 sept. 2012, 16:36

C'est normal que tu ne soit pas à jour ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Feng
yeomen
Messages : 273
Inscription : mer. 07 avr. 2010, 20:19

Re: [AUR] impossible d'installer cloop.

Message par Feng » jeu. 13 sept. 2012, 16:36

La cloop c'est mal.

oktoberfest
Maître du Kyudo
Messages : 1855
Inscription : mer. 06 janv. 2010, 13:51
Localisation : Ried - Alsace - France

Re: [AUR] impossible d'installer cloop.

Message par oktoberfest » jeu. 13 sept. 2012, 16:36

Mets à jour ton système avant de compiler.
La majorité des bugs se situe entre la chaise et le clavier...
Arrêtez de vous prendre la tête avec les partitions... passez au LVM

Avatar de l’utilisateur
Anghirrim
Elfe
Messages : 692
Inscription : mar. 28 févr. 2012, 11:09
Localisation : Loire-Atlantique

Re: [AUR] impossible d'installer cloop.

Message par Anghirrim » jeu. 13 sept. 2012, 16:52

Oups, j'avais oublié que j'étais sur une machine virtuelle pas forcément à jour.... :oops:

Je retente dès que possible.

Merci!
Tour Intel© Core™ i5-4670, Arch Linux Cinnamon + Windows 10
Asus X53S, Linux Mint Tricia 19.3 Cinnamon

Avatar de l’utilisateur
Anghirrim
Elfe
Messages : 692
Inscription : mar. 28 févr. 2012, 11:09
Localisation : Loire-Atlantique

Re: [AUR] impossible d'installer cloop.

Message par Anghirrim » jeu. 13 sept. 2012, 18:20

Bon, j'ai bien installé cloop.

Seulement impossible de le charger, la commande modprobe me retourne "Impossible de trouver le module". J'ai tenté en le mettant dans le /etc/mkinitcpio.conf, mais même résultat...

cloop n'est pas censé être un module?
Tour Intel© Core™ i5-4670, Arch Linux Cinnamon + Windows 10
Asus X53S, Linux Mint Tricia 19.3 Cinnamon

benjarobin
Maître du Kyudo
Messages : 15903
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [AUR] impossible d'installer cloop.

Message par benjarobin » jeu. 13 sept. 2012, 18:25

Fait : depmod -a
Si cela ne résout pas le problème, donne la sortie de : pacman -Qlq cloop
Sinon enlève le de /etc/mkinitcpio.conf, je en pense pas que ce soit une bonne idée :D
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Anghirrim
Elfe
Messages : 692
Inscription : mar. 28 févr. 2012, 11:09
Localisation : Loire-Atlantique

Re: [AUR] impossible d'installer cloop.

Message par Anghirrim » ven. 14 sept. 2012, 17:14

depmod -a a fonctionné.

Merci!!
Tour Intel© Core™ i5-4670, Arch Linux Cinnamon + Windows 10
Asus X53S, Linux Mint Tricia 19.3 Cinnamon

benjarobin
Maître du Kyudo
Messages : 15903
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [AUR] impossible d'installer cloop.

Message par benjarobin » ven. 14 sept. 2012, 17:18

:resolu: ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Anghirrim
Elfe
Messages : 692
Inscription : mar. 28 févr. 2012, 11:09
Localisation : Loire-Atlantique

Re: [AUR] impossible d'installer cloop.

Message par Anghirrim » sam. 15 sept. 2012, 15:31

Pas encore, pas encore... :mrgreen: :mrgreen:

J'ai un souci de lecture seule sur le fichier. Je vous poste le message plus tard, je n'ai pas la machine sous la main.
Tour Intel© Core™ i5-4670, Arch Linux Cinnamon + Windows 10
Asus X53S, Linux Mint Tricia 19.3 Cinnamon

Avatar de l’utilisateur
Anghirrim
Elfe
Messages : 692
Inscription : mar. 28 févr. 2012, 11:09
Localisation : Loire-Atlantique

Re: [AUR] impossible d'installer cloop.

Message par Anghirrim » sam. 22 sept. 2012, 11:45

Bon, j'ai contourné le problème en faisant ce que je voulais sous un KNOPPIX. Je place donc ce sujet en contourné.

Merci à tous.
Tour Intel© Core™ i5-4670, Arch Linux Cinnamon + Windows 10
Asus X53S, Linux Mint Tricia 19.3 Cinnamon

Répondre