[lupac] trouver les paquetages inutiles de votre système

Mise à jour / Création /debug de paquetages
Avatar de l’utilisateur
wain
Maître du Kyudo
Messages : 1854
Inscription : ven. 11 août 2006, 19:15
Localisation : Nancy (54)
Contact :

[lupac] trouver les paquetages inutiles de votre système

Message par wain » lun. 18 févr. 2008, 23:40

venox (du bbs anglais) a créé un superbe outil: lupac, qui permet de retrouver les paquetages inutilisés depuis un certains temps et qui squattent votre disque dur.

L'annonce sur le forum: http://bbs.archlinux.org/viewtopic.php?id=43962
La page sur AUR: http://aur.archlinux.org/packages.php?d ... 1&ID=15198

Installation:

Code : Tout sélectionner

yaourt -S lupac
Exemple d'utilisation:

Code : Tout sélectionner

lupac -sya 90
Vous donnera la liste de tous les paquetages inutilisés depuis plus de 90 jours (hormis les paquetages installés comme dépendances et donc toujours nécessaire au fonctionnement).

Bon ménage ! :D

Avatar de l’utilisateur
Archie
yeomen
Messages : 257
Inscription : jeu. 28 juin 2007, 22:18
Localisation : France (33)

Message par Archie » mar. 19 févr. 2008, 00:56

Code : Tout sélectionner

chocolat archie|~ § lupac -sya 90
Fetching packages database from pacman...  OK
Parsing database...  OK
Sorting results...  OK

System packages sorted by usage:
flover                       169 days
xf86-video-vesa              131 days
timidity-freepats            103 days
hdparm                       90 days
dosfstools                   90 days
reiserfsprogs                90 days
grub                         90 days
jfsutils                     90 days
lilo                         90 days
rp-pppoe                     90 days
A ben tient c'est bizarre, j'ai Grub et lilo d'installés !
M'aura fait au moins découvrir ça ce logiciel :D

169 jours pour l'extension flover, que j'ai jamais réussi à faire fonctionner. Qui a découvert pire dans son grenier ? :lol:

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1121
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Message par Skunnyk » mar. 19 févr. 2008, 14:21

Et bé... j'ai pire !

Code : Tout sélectionner

[skunnyk@F3nR1l ~]$ lupac -sya 90
Fetching packages database from pacman...  OK
Parsing database...  OK
Sorting results...  OK

System packages sorted by usage:
ddcxinfo-arch                      540 days
gkx86info                          486 days
gkrellm-themes                     486 days
perl-net-snmp                      417 days
resourceproto                      369 days
xcmiscproto                        369 days
xf86bigfontproto                   369 days
evieext                            369 days
xf86driproto                       369 days
damageproto-git                    365 days
randrproto-git                     365 days
openoffice-spell-fr                327 days
blktool                            272 days
python-mpdclient2                  218 days
plib                               140 days
fping                              125 days
python-soappy                      114 days
gooeypy                            109 days
libxtrap                           99 days
libnetworkmanager                  99 days
glitz-cvs                          99 days
libxml++2                          99 days
at-spi                             99 days
libdmx                             99 days
xf86-video-vesa                    99 days
J'ai pas regardé le man savoir comment ça fonctionne, mais genre "openoffice-spell-fr" il me semble m'en servir vu que OOo me corrige mes fautes :p

Avatar de l’utilisateur
wain
Maître du Kyudo
Messages : 1854
Inscription : ven. 11 août 2006, 19:15
Localisation : Nancy (54)
Contact :

Message par wain » mar. 19 févr. 2008, 14:47

Skunnyk a écrit :J'ai pas regardé le man savoir comment ça fonctionne, mais genre "openoffice-spell-fr" il me semble m'en servir vu que OOo me corrige mes fautes :p
Peut-être que ton openoffice utilise les dictionnaires téléchargés par l'extension dicooo ? Je sais pas trop... faudrait désinstaller openoffice-spell-fr (qui date quand même de 2005) et regarder si openoffice corrige encore les fautes.
Le fonctionnement du logiciel lupac est assez simple. Pour chaque paquetage installé, lupac regarde la date du dernier accès de chacun des fichiers fournis. C'est la date la plus récente trouvée qui donne au final la date de dernière utilisation du paquetage.

hebus
Daikyu
Messages : 63
Inscription : jeu. 21 sept. 2006, 12:46
Contact :

Message par hebus » mar. 19 févr. 2008, 18:41

hebus]# lupac -sya 90
Fetching packages database from pacman... OK
Parsing database... OK
Sorting results... OK

System packages sorted by usage:
xcursor-themes 780 days
openoffice-spell-fr 377 days
xfce4-trigger-launcher 376 days
amarok-lite 343 days
vmware-server-modules 340 days
xffm 295 days
grub 287 days
unifdef 271 days
nzbget 271 days
lshwd 271 days
gputils 271 days
apache-ant 271 days
fortune-mod 264 days
pacstats 259 days
argouml 250 days
xalan-java 244 days
docbook-xml 223 days
gstreamer0.10-flac 157 days
libxtrap 97 days
libnetworkmanager 97 days
libsvg-cairo 97 days
glew 97 days
gpsim 97 days
libraw1394 97 days
tls 97 days
gtksourceview 97 days
jasper 97 days
libsmbios 97 days
cyrus-sasl 97 days
rarian 97 days
alsa-oss 97 days
db4.1 97 days
icu 97 days
heliodor 97 days
versionpkg 97 days
xtrans 97 days
gnome-common 97 days
Oué quand même ... J'ai du boulot ? Vraiment cool comme outils.

J'ai quand même un problème ... J'ai mon PC que depuis decembre 2006. Soit pas encore 2 ans ... Et y a que 365 jours dans l'année non ?
Et ... j'utilise grub aussi.

Avatar de l’utilisateur
wain
Maître du Kyudo
Messages : 1854
Inscription : ven. 11 août 2006, 19:15
Localisation : Nancy (54)
Contact :

Message par wain » mar. 19 févr. 2008, 19:53

ouais t'as des résultats chelou. On va dire que cet outil peut donner des résultats imprévisibles et qu'il convient de toujours bien vérifier avant de supprimer quoi que ce soit :nage: :moderationok:

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1121
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Message par Skunnyk » mar. 19 févr. 2008, 19:59

Et si oon monte notre FS avec l'option noatime, le script il ne fonctionne plus ? :p Mais en tout cas c'est tjrs sympa ce genre d'outils, ca permet de se rendre qu'on a plein de trucs d'inutilisé ^^

Avatar de l’utilisateur
Tebo
Chu Ko Nu
Messages : 368
Inscription : sam. 17 mars 2007, 23:24

Message par Tebo » mar. 19 févr. 2008, 20:07

Je préfère un petit yaourt -Qt :)

Avatar de l’utilisateur
mimas
Elfe
Messages : 559
Inscription : sam. 30 sept. 2006, 22:30
Localisation : Toulouse

Message par mimas » mar. 19 févr. 2008, 20:34

Skunnyk a écrit :Et si oon monte notre FS avec l'option noatime, le script il ne fonctionne plus ? :p
Je ne crois pas qu'il fonctionne avec noatime. Par contre tu peux essayer relatime.
Anarchy for the triple A.

Avatar de l’utilisateur
Archie
yeomen
Messages : 257
Inscription : jeu. 28 juin 2007, 22:18
Localisation : France (33)

Message par Archie » mar. 19 févr. 2008, 20:54

hebus a écrit :xcursor-themes 780 days
A ouai quand même :o

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Message par mélodie » mar. 19 févr. 2008, 22:15

Comment faites-vous pour l'installer ?
==> Starting build()...
install: cannot stat `lupac-0.0.7a': No such file or directory
==> ERROR: Build Failed. Aborting...
Error: Makepkg was unable to build lupac package.

hebus
Daikyu
Messages : 63
Inscription : jeu. 21 sept. 2006, 12:46
Contact :

Message par hebus » mar. 19 févr. 2008, 22:52

Mon FS c'est du reiserfs. Je sais pas comment ca fonctionne,

Ça peu avoir un rapport ?

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Message par tuxce » mar. 19 févr. 2008, 23:59

mélodie a écrit :Comment faites-vous pour l'installer ?
ca fonctionne avec yaourt ou sinon:

Code : Tout sélectionner

wget http://files.venox.qc.to/lupac-0.0.7a
chmod +x lupac-0.0.7a
./lupac-0.0.7a -sya 90 

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Message par mélodie » mer. 20 févr. 2008, 00:04

tuxce a écrit : ca fonctionne avec yaourt ou sinon
Ah merci. Finalement je l'ai installé avec yaourt -S car wain l'a uploadé sur le dépôt.

Avatar de l’utilisateur
Jeanuel
Hankyu
Messages : 38
Inscription : mer. 24 oct. 2007, 13:16

Message par Jeanuel » mar. 11 mars 2008, 22:38

Je vais faire une entrée dans le wiki. C'est trop utile !

Avatar de l’utilisateur
marc[i1]
Maître du Kyudo
Messages : 1753
Inscription : ven. 27 oct. 2006, 10:48
Localisation : Nantes (44)
Contact :

Re: [lupac] trouver les paquetages inutiles de votre système

Message par marc[i1] » mer. 31 août 2011, 23:48

Plop … voilà j’exhume un (très) vieux sujet pour la bonne cause.

lupac est mis à jour sur AUR et pour ceux qui ne connaissent pas … c’est bien pratique :)
Ne vous emmerdez plus, emmerdez les autres.

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1138
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [lupac] trouver les paquetages inutiles de votre système

Message par karhu » sam. 03 sept. 2011, 11:01

Bonjour
Merci pour la mise à jour, intéressante la sortie de lupac, mais bien regarder avant de supprimer !
@marc[i1]
Il y a toujours l'avertissement nous invitant à changer la dépendance de python2 en python.
N'y avait il pas moyen de faire cette modification lors de la mise à jour ?
Éditer pkgbuild et supprimer un "2" n'est pas bien compliqué d'accord, mais combien lisent les avertissements ?
J'ai une question, peut-être hors sujet, mais tant pis. Avec la liste établie par lupac je découvre un paquet inutilisé : pygtksourceview2. Avant de le supprimer je vérifie s'il n'est pas requis par quelqu'un, voilà le problème

Code : Tout sélectionner

> yaourt -Qid pygtksourceview2 
Nom                   : pygtksourceview2
Version               : 2.10.1-3
URL                   : http://www.gnome.org
Licences              : GPL
Groupes               : --
Fournit               : --
Dépend de             : gtksourceview2>=2.10.0  pygtk>=2.17.0
Dépendances opt.      : --
Requis par            : --
Est en conflit avec   : --
Remplace              : --
Taille (installé)     : 256,00 K
Paqueteur             : Allan McRae <allan@archlinux.org>
Architecture          : x86_64
Compilé le            : jeu. 07 oct. 2010 07:35:02 CEST
Installé le           : mer. 20 oct. 2010 13:56:41 CEST
Motif d'installation  : Installé comme dépendance d'un autre paquet
Script d'installation : Non
Description           : Python bindings for gtksourceview2
Il n'est requis par personne MAIS il a été installé comme dépendance.
Existe t il déjà un moyen de remonter la chaîne des dépendances ?
Karhu.
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

benjarobin
Maître du Kyudo
Messages : 15923
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [lupac] trouver les paquetages inutiles de votre système

Message par benjarobin » sam. 03 sept. 2011, 12:49

Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1138
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [lupac] trouver les paquetages inutiles de votre système

Message par karhu » sam. 03 sept. 2011, 14:02

Merci benjarobin, seulement j'avais déjà regardé là avant d'écrire.
Le mystère reste entier car sur les quatres programmes mentionnés je n'en ai installé aucun !
Avant d'écrire un petit (gros) script qui recherche la chaîne "pygtksourceview2" dans tous mes paquets installés, j'essaye de voir s'il n'y a pas un moyen plus simple. :P
Karhu.
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

benjarobin
Maître du Kyudo
Messages : 15923
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [lupac] trouver les paquetages inutiles de votre système

Message par benjarobin » sam. 03 sept. 2011, 14:47

Le paquet n'existe tout simplement plus. Le plus simple est de faire une recherche dans le log de pacman. Mais si j’étais toi je supprimerai tout simplement le paquet car il n'est plus nécessaire, et au pire si ce n'est pas le cas il suffira de le réinstallé.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Répondre