[système] lent (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
benjarobin
Maître du Kyudo
Messages : 15562
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [système] lent (en cours)

Message par benjarobin » dim. 27 juil. 2014, 19:20

Le coupable me parait évident... C'est le programme Tracker qui index ton disque dur.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Elvish
Hankyu
Messages : 42
Inscription : ven. 07 févr. 2014, 23:02

Re: [système] lent (en cours)

Message par Elvish » dim. 27 juil. 2014, 19:22

j'en ai aucune utilité, je ne fais jamais de recherches si ce n'est dans le terminal avec locate et updatedb
c'est le même soft ?

Elvish
Hankyu
Messages : 42
Inscription : ven. 07 févr. 2014, 23:02

Re: [système] lent (en cours)

Message par Elvish » dim. 27 juil. 2014, 19:31

hop, je l'ai retiré en démarrage automatique et j'ai mis les préférences sur seulement en inutilisation ; je vais voir si c'était bien ça, mais je pense que oui (jespère !)

merci

benjarobin
Maître du Kyudo
Messages : 15562
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [système] lent (en cours)

Message par benjarobin » dim. 27 juil. 2014, 19:31

Tracker est un programme de Gnome, et n'est absolument pas lié à la commande locate, dont l'indexer est en effet updatedb.
Si tu as d'autres ralentissement du même genre, toujours avoir le réflexe de faire un htop et un iotop
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Elvish
Hankyu
Messages : 42
Inscription : ven. 07 févr. 2014, 23:02

Re: [système] lent (en cours)

Message par Elvish » dim. 27 juil. 2014, 22:56

d'accord

c'est bien récalcitrant, après avoir refuser le démarrage automatique au startup, voilà qu'il se met à tourner quand j'utilise mon ordinateur.
comment tuer le PID efficacement ? une simple commande kill ne suffit apparemment pas

aussi j'aimerais vraiment retirer ce truc définitivement, ça ralenti vraiment et je ne peux même pas arrêter le système lors des analyses

benjarobin
Maître du Kyudo
Messages : 15562
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [système] lent (en cours)

Message par benjarobin » dim. 27 juil. 2014, 23:12

Il ne faut pas le killer... Il faut le désactiver proprement ou le désinstaller...
Je n'ai pas Gnome, mais le premier lien Google me donne ceci : https://ask.fedoraproject.org/en/questi ... e-tracker/
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Elvish
Hankyu
Messages : 42
Inscription : ven. 07 févr. 2014, 23:02

Re: [système] lent (en cours)

Message par Elvish » lun. 28 juil. 2014, 12:10

dans le sens où il me pompe toute mes ressources et que je ne peux plus rien à faire, oui, j'ai tenté le kill.

et j'utilise XFCE

bobo
Elfe
Messages : 554
Inscription : mar. 08 avr. 2014, 22:47

Re: [système] lent (en cours)

Message par bobo » lun. 28 juil. 2014, 18:04

Tracker sur le wiki archlinux :
https://wiki.archlinux.org/index.php/Gn ... program.29

Tu peux peut-être voir si tu ne peux pas bricoler avec :

Code : Tout sélectionner

tracker-preferences
Édit : J'imagine que tu as tenté un :

Code : Tout sélectionner

pacman -R tracker
Ça donne quoi ?
dwm — BÉPO — vim — “more is less !”

Elvish
Hankyu
Messages : 42
Inscription : ven. 07 févr. 2014, 23:02

Re: [système] lent (en cours)

Message par Elvish » lun. 28 juil. 2014, 19:22

merci pour ces commandes bobo

j'ai désactivé toutes les préférences avec /tracker-preferences/ - mais j'aimerais bien le vaquer de mon système ^^

j'avais bien sûr essayé un remove via pacman, mais il y a un problème de dépendances. oui, certaines applications ont besoin de ce tracker

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
:: bijiben : requiert tracker
:: gnome-documents : requiert tracker
:: gnome-music : requiert tracker
:: gnome-online-miners : requiert tracker
:: gnome-photos : requiert tracker
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

comme j"utilise XFCE, où est le mal ? à moins que celui-ci utilise des éléments de GNOME essentiels
si vraiment c'est nécessaire, tant pis. sinon, pouvez-vous me donner un argument après /pacman/ qui permet d'ignorer les erreurs et de forcer la désinstallation ?

benjarobin
Maître du Kyudo
Messages : 15562
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [système] lent (en cours)

Message par benjarobin » lun. 28 juil. 2014, 20:20

Tout est possible avec pacman, mais si tu aimes vraiment casser ton système je ne vais que dire : voir le man de pacman
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Elvish
Hankyu
Messages : 42
Inscription : ven. 07 févr. 2014, 23:02

Re: [système] lent (en cours)

Message par Elvish » lun. 28 juil. 2014, 20:39

je pense pas que ça 'casse' le système comme tu l'entends. il s'agit d'un utilitaire sans grande utilisé pour moi, la recherche (tracker) sera ainsi arrêtée sans problème - j'espère

je vais voir du côté de pacman, je pensais qu'il existait un argument simple de type -F

benjarobin
Maître du Kyudo
Messages : 15562
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [système] lent (en cours)

Message par benjarobin » lun. 28 juil. 2014, 21:02

:| :dodo: :roll: :non:
Plus sérieusement, tracker serait en dépendance optionnel si cela avait été le cas...
Le paquet tracker https://www.archlinux.org/packages/extr ... ker/files/ fournit des bibliothèques pour que les applications puissent l'utiliser.
Les applications qui dépendent de tracker sont linker dynamiquement avec ces librairies de tracker. Si tu supprimes tracker, les applications compilées et liées à tracker ne pourront plus se lancer.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

bobo
Elfe
Messages : 554
Inscription : mar. 08 avr. 2014, 22:47

Re: [système] lent (en cours)

Message par bobo » lun. 28 juil. 2014, 21:24

La question est donc « comment supprimer Gnome proprement ? »

Je serais toi je ferais ça pour voir s'il y a encore plein de dépendances :

Code : Tout sélectionner

pacman -R tracker bijiben gnome-documents gnome-music gnome-online-miners gnome-photos

Comment je m'y prendrais après avoir regardé chez moi :

Si ça devient trop fastidieux, il va falloir penser à faire une ablation de tout gnome :

Code : Tout sélectionner

pacman -Rp gnome
pacman -Rpc gnome
Ça devrait te faire une liste des paquets qui déconnent, l'option « p » permet de faire une liste sans rien effacer pour de vrai (une sorte de simulation). L'option « c » supprime les paquets en « cascade » et va tout virer ce qui dépend des paquets listés. Si tu compares les 2 listes tu devrais avoir une idée, de la dangerosité de la manip.

Maintenant que j'y pense, ça pourrait être pas mal de voir ce que donnent ces commandes :

Code : Tout sélectionner

pacman -Rpc tracker
pacman -Rpcs tracker
pacman -Rpcss tracker
pacman -Rpcssu tracker
(l'option « s(s) » permet la suppression récursive, les paquets qui n'ont plus de dépendances sont effacés, l'option « u » est assez floue pour moi pour le moment)

NB : ne supprime l'option « p » qu'une fois que tu es sûr·e de ton coup
Édit : je viens de me rendre compte qu'avec « -Rp » tu peux lancer pacman sans droit admin !! J'adore ce gestionnaire de paquet
dwm — BÉPO — vim — “more is less !”

Elvish
Hankyu
Messages : 42
Inscription : ven. 07 févr. 2014, 23:02

Re: [système] lent (en cours)

Message par Elvish » lun. 28 juil. 2014, 22:09

cool, merci encore pour toutes ces commandes bobo et leurs explications précises, ça m'a bien aidé

j'ai opté pour une simple ablation, comme tu dis, de tracker et les dépendances qui y sont associées ; elles s'arrêtaient à celles que j'avais exposées plus haut, donc 6.

voilà ; je reviens vous confirmer qu'il n'y ait plus de problème à plusieurs utilisations du système

merci encore !

bonne soirée

Elvish
Hankyu
Messages : 42
Inscription : ven. 07 févr. 2014, 23:02

Re: [système] lent (en cours)

Message par Elvish » mar. 29 juil. 2014, 22:35

bon, j'ai un autre problème cette fois-ci avec le procesus nommé "kworker" - de la documentation est disponible à ce sujet mais elle est en anglais et le problème est peu connu

http://img15.hostingpics.net/pics/6731042701.png

vous en dites quoi... ?

édition

une commande circule et semblerait résoudre le soucis :

Code : Tout sélectionner

echo disable > /sys/firmware/acpi/interrupts/gpe01
?

benjarobin
Maître du Kyudo
Messages : 15562
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [système] lent (en cours)

Message par benjarobin » mar. 29 juil. 2014, 23:07

Cela me parait plus évident que c'est deluge qui consomme des ressources... Après tu ne dois pas avoir un disque dur très véloce, cela n'aide surement pas...
Sinon tu confonds consommation CPU vs IO pour kworker.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Elvish
Hankyu
Messages : 42
Inscription : ven. 07 févr. 2014, 23:02

Re: [système] lent (en cours)

Message par Elvish » mar. 29 juil. 2014, 23:22

non, deluge ne consomme pas tant de ressources ; et en l'occurence il n'était pas en cours d'execution lors des bugs, hormi pour le screen.

ensuite j'aimerais que tu évites ces allégations à propos de mon disque dur, ou même de mon ignorance sur le sujet, d'autant plus que tes messages ne me sont pas d'une grande aide... je rappelle qu'on est sur un forum, et toi mis à part me reprendre sur mes mots tu ne me fournis aucune aide, contrairement à d'autres, tels bobo. je te remercie d'ailleurs.

mon disque dur n'est pas super puissant, mais pour une utilisation basique il est à la hauteur... par ailleurs je ne pense pas que deluge, même s'il consomme des ressources, parvienne à faire buguer tout mon système. d'ailleurs, il n'est plus en cours d'execution à l'heure où j'écris et le système est toujours lent, avec kworker en fonctionnement.

voilà donc, la théorie selon laquelle ce serait deluge le pb est désormais réfutée... et j'aimerais qu'on se penche sur kworker. plusieurs témoignagnes sont présents sur la toile sur ce processus qui consomme beaucoup :')

bonne soirée, et merci aux éventuelles aides

bobo
Elfe
Messages : 554
Inscription : mar. 08 avr. 2014, 22:47

Re: [système] lent (en cours)

Message par bobo » mer. 30 juil. 2014, 00:19

olaah… il faudrait pas s'enflammer : ça reste un forum :mrgreen: et sans smiley des propos peuvent très vite être mal interprétés :wink:

:arrow: deluge
Je ne sais pas d'où sort l'idée sur deluge, mais il me semble que benjarobin doit avoir bien suivi le cas pour choper de tels infos :chinois: . Ça pourrait être pas mal de désactiver le soft s'il tourne vraiment en tâche de fond et de voir si ça change quelque chose.

:arrow: kworker

Je n'en ai jamais entendu parlé, j'ai 20 processus kworker et ça ne semble pas me plomber les perfs… Il va falloir que j'enquête là-dessus.

:arrow: Pour ces soucis de systèmes lents
S'il semble y avoir une couille, le mieux reste de décorréler les différentes causes. Par exemple, un exercice intéressant serait :
– d'utiliser un autre utilisateur « vierge » sur le même environnement de bureau
– d'utiliser avec le même utilisateur un environnement de bureau différent

Là-dessus faire testcases pour essayer de provoquer les lenteurs et voir ce qui déconne, essayer de décrire au mieux les soucis que tu rencontres.

Et peut-être le principe premier de pas mal de forums d'aide d'utilisateurs Linux : « un problème = un sujet ». Sur ce fil on a déjà résolu :
— une partition racine pleine, cause cache pacman trop gros
— une neutralisation de tracker, qui avait l'air du DDOS sur une partition ntfs

C'est déjà pas mal :D Pour la suite, je te suggérerais bien d'ouvrir un sujet à part pour kworker (mentionnant kworker explicitement dans le texte), en mettant les liens des infos en Anglais qui te paraissent pertinentes. Ça pourrait parler à des utilisateurs qui passeraient par là ;)
dwm — BÉPO — vim — “more is less !”

Elvish
Hankyu
Messages : 42
Inscription : ven. 07 févr. 2014, 23:02

Re: [système] lent (en cours)

Message par Elvish » mer. 30 juil. 2014, 00:30

Aucunement bobo, je ne m’enflamme pas. C'est juste que les réponses concises de benjarobin ne m'aident pas vraiment... pour ne pas dire pas du tout. Limite il n'a pas envie de répondre et je le fais chier ; sauf que nous sommes sur un forum comme tu le rappelles et ceci prône le partage et l'entraide ;)
De plus il est ici de son plein gré

Tu conviendras qu'elles ne sont pas d'une grande aide. Enfin...

Là encore, toi, tu me fais un long texte explicatif et bien détaillé qui m'aide grandement, et ça, j'aime :)
Merci. Je verrai ça demain.

benjarobin
Maître du Kyudo
Messages : 15562
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [système] lent (en cours)

Message par benjarobin » mer. 30 juil. 2014, 10:57

d'autant plus que tes messages ne me sont pas d'une grande aide
Hum, je vais essayer de rester courtois car comme je suis modérateur je le dois.
Mes messages sont succins certes mais contiennent toutes les informations nécessaire pour faire avancer le sujet. Pas besoin de faire un roman (Cela ne t'ai pas visé bobo).
J'ai relu depuis le début le sujet, et j'ai plutôt l'impression d'avoir été l'unique personne à faire avancer le sujet. bobo t'a juste indiqué comment supprimer un paquet et d'autres détails (merci à lui), chose qu'il n'aurait jamais eu besoin de faire, car tu aurais du chercher un minimum avant. Les informations étant dans le Wiki ou dans les man associés...
J'essaye de donner des pistes aux utilisateur en "détresse", mais en aucun cas je vais donner la main et tout expliquer, ce n'est pas ma philosophie. Si la personne pose une question ciblée et qu'il montre avoir cherché dans le man/doc, alors je serais ravi d'y répondre.

Pour kworker, ce ne sont pas des processus mais des threads internes au kernel. Ils peuvent en effet provoquer des ralentissement s'il y a un bug dans le kernel, mais ces ralentissements/bug seraient du à une forte consommation CPU, et non d'IO. Je ne connait aucun bug (que je sache) dans un thread kworker qui provoque une forte consommation des accès disque.

Sinon je ne vois pas en quoi ma remarque sur le disque dur était désobligeante ? Ce n'est qu'un disque dur...

Sur ce, je te souhaite une bonne résolution de ton problème, je ne répondrais plus à ce sujet (normalement) mais je suis très curieux de savoir ce qui provoque ces ralentissements.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Répondre