[afur] paquets périmés

annonces et demandes de paquetages pour les dépôts i686 et x86_64
Répondre
Avatar de l’utilisateur
LeRieur
newbie
Messages : 2
Inscription : mer. 12 nov. 2014, 00:29

[afur] paquets périmés

Message par LeRieur » mar. 02 déc. 2014, 08:20

Bonjour,

Plusieurs versions de paquets dans AFUR sont périmées et n'ont pas été signalées. Des versions plus récentes sont disponibles dans AUR:
- acroread: 9.5.5-3 -> 9.5.5-5
- bibtex2html: 1.97-3 -> 1.98-1
- downgrade: 5.0.3-1 -> 5.1.1-1
- linpack: 11.1.3.006-2 -> 11.2.1.009-2
- openbox-menu: 0.5.1-1 -> 0.7.0-1
- scilab: 5.5.0-2 -> 5.5.1-3
- stapler: (0.)2b-3 -> 0.4-2
- petsc: 3.4.4-1 -> 3.5.1-1 (3.5.2 disponible)
- pyromaths: 13.03-1 -> 14.06-1
- qgis: 2.4.0-4 -> 2.6.1-1
- winusb: 1.0.11-4 -> 1.0.11-5
- xscreensaver-arch-logo: 5.26-3 -> 5.32-1

Des paquets à modifier:
- plowshare-svn -> plowshare-git

D'autres paquets ne sont plus disponibles dans AUR, et le lien est toujours fait dans AFUR:
- trayfreq-fr

Des paquets disponibles sur AUR mais dont le lien n'est pas fait dans AFUR:
- openblas


Aussi, ne serait-il pas intéressant de créer un topic épinglé où tout utilisateur du forum pourrait signaler des paquets périmés dans le dépôt? (au lieu de créer à chaque fois un nouveau topic)

Merci.

benjarobin
Maître du Kyudo
Messages : 15533
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [afur] paquets périmés

Message par benjarobin » mar. 02 déc. 2014, 09:28

@Aux admins / modérateurs : Il n'y avait pas un script qui s'occupait de signaler automatiquement les paquets non à jour ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
coincoin
Daikyu
Messages : 82
Inscription : sam. 12 janv. 2013, 21:19

Re: [afur] paquets périmés

Message par coincoin » mar. 02 déc. 2014, 09:35

Bonjour,

Je m'occupe d'updater les paquets que je maintiens (acroread, bibtex2html, downgrade, linpack, scilab, petsc, xscreensaver-arch-logo et qgis).
Je ne suis pas sûr que ce soit toujours judicieux de les qualifier de périmés car ils n'entraînent à priori pas de conflits par rapport à d'autres paquets.
Les mises à jours de certains sont fréquentes et par rapport à d'autres distributions on est bien en avance.

Pour les liens qui n'ont pas été faits entre AFUR et AUR, celà est dû à un code qui a été implémenté récemment il n'est pas 100% fiable (autre ex : la version afur de dropbox est en rouge alors que celle de AUR est la même).

Je pense que le plus simple est de laisser la possibilité de s'inscrire et de flagger si un paquet est périmé ce qui envoie un message mail au mainteneur.
\_o<

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10533
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [afur] paquets périmés

Message par FoolEcho » mar. 02 déc. 2014, 10:35

benjarobin a écrit :@Aux admins / modérateurs : Il n'y avait pas un script qui s'occupait de signaler automatiquement les paquets non à jour ?
Normalement si... :cry: (vu que c'est moi qui l'avait fait :mrgreen: )... Je subodore un oubli de lancement de la tâche cron chargé du suivi des versions entre afur et aur sur le serveur puisque l'infrastructure a changé entretemps si j'ai bien suivi (je vais faire remonter ça).

Si j'avais jeté un œil à afur comme avant, je l'aurais remarqué beaucoup plus tôt... :oops:
LeRieur a écrit :Aussi, ne serait-il pas intéressant de créer un topic épinglé où tout utilisateur du forum pourrait signaler des paquets périmés dans le dépôt? (au lieu de créer à chaque fois un nouveau topic)
À voir... Des sujets séparés permettent un suivi plus simple (on met à jour et on passe à autre chose). Un sujet unique et on risque de passer des choses à l'index.

EDIT: bon... le script a bel et bien un soucis qui devrait être corrigé sous peu... :(
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10533
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [afur] paquets périmés

Message par FoolEcho » mer. 03 déc. 2014, 13:19

Voilà... le script est a priori fonctionnel de nouveau. :-)

Si certains paquets ne sont pas marqués comme périmés en dépit de ce que montre le tri, c'est aussi parce qu'on a pris le pli de ne pas notifier les mainteneurs lorsque le changement est cosmétique et n'impacte pas le paquet final (par exemple une révision mineure au niveau du PKGBUILD à version de logicielle égale).

@coincoin: à toi de voir ce que tu fais de plowshare-svn, mais a priori il faudrait le supprimer et passer à plowshare-git comme suggéré par LeRieur. Et en vertu de la licence d'adobe, j'ai supprimé acroread (pas le droit de diffuser le logiciel). :chinois:

@LeRieur: merci des remontées et notamment concernant stapler (le numéro de version initiale étant mal fait, il aurait fallu attendre un bail avant de s'apercevoir du problème :mrgreen: ).
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
coincoin
Daikyu
Messages : 82
Inscription : sam. 12 janv. 2013, 21:19

Re: [afur] paquets périmés

Message par coincoin » jeu. 04 déc. 2014, 10:45

@FoolEcho
Merci pour l'update du script ça a l'air nickel.
Ok pour acroread, je ne savais pas.
Quant à plowshare-svn ce n'est pas moi qui le maintient mais biginoz ^^.
\_o<

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10533
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [afur] paquets périmés

Message par FoolEcho » jeu. 04 déc. 2014, 13:09

coincoin a écrit :Quant à plowshare-svn ce n'est pas moi qui le maintient mais biginoz ^^.
Ah exact... du coup je vais lui notifier. :chinois:
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [afur] paquets périmés

Message par Xorg » dim. 07 déc. 2014, 15:29

FoolEcho a écrit :Voilà... le script est a priori fonctionnel de nouveau. :-)
Et tu penses que c'est possible qu'un script aille chercher sur Internet si de nouvelles versions sont disponibles (d'après ce que j'ai lu, le votre compare les versions entre AFUR et AUR) ? Ça peut m'intéresser pour les paquets que j'ai sur AUR, parce que je ne connais que la méthode classique, à savoir aller voir soi-même... :mrgreen:
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

benjarobin
Maître du Kyudo
Messages : 15533
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [afur] paquets périmés

Message par benjarobin » dim. 07 déc. 2014, 16:42

Personnellement je me suis fait un script pour certain paquet AUR (je ne sais pas s'ils fonctionnent toujours...), ces scripts sont exécutés via cron.
Et en gros le script il télécharge la page web qui contient la version et fait un grep dessus, si la version n'est pas trouvée, j’écris un fichier. Et puis lorsque j'ouvre une console le shell affiche le contenu du fichier s'il existe. C'est très rudimentaire mais cela fonctionne assez bien.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10533
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [afur] paquets périmés

Message par FoolEcho » dim. 07 déc. 2014, 19:48

Xorg a écrit :
FoolEcho a écrit :Voilà... le script est a priori fonctionnel de nouveau. :-)
Et tu penses que c'est possible qu'un script aille chercher sur Internet si de nouvelles versions sont disponibles (d'après ce que j'ai lu, le votre compare les versions entre AFUR et AUR) ? Ça peut m'intéresser pour les paquets que j'ai sur AUR, parce que je ne connais que la méthode classique, à savoir aller voir soi-même... :mrgreen:
Ben... on peut à peu près faire ce qu'on veut... ^^
Néanmoins le script actuel sur afur s'appuie sur les bases de données qui enregistrent les différents paquets disponibles sur afur (comprendre par là: et pas sur une liste des paquets installés puisque ce n'est pas ce dont on dispose pour le dépôt, donc pour le côté transposable à un utilisateur et son installation, c'est sans doute zéro).
En l'état, la vérification n'est faite que périodiquement (pour du dynamique et faire bosser le client plutôt que le serveur, il faudrait faire une autre version à coup de JQuery par exemple... tuxce avait planché dessus mais finalement j'ai été le plus rapide ^^ ... les deux approches ont leurs avantages et leurs défauts... :( ).
benjarobin a écrit :Et en gros le script il télécharge la page web qui contient la version et fait un grep dessus, si la version n'est pas trouvée, j’écris un fichier. Et puis lorsque j'ouvre une console le shell affiche le contenu du fichier s'il existe. C'est très rudimentaire mais cela fonctionne assez bien.
Par contre, sur afur on a recours à AurJson, ce qui permet d'avoir des requêtes et des analyses plus ciblées (et donc pour afur, on stocke dans une table la version sur AUR que l'on compare ensuite pour le tri). :chinois:

Mais je réponds peut-être à côté de la plaque si la question était de savoir comment être informé si un projet donné propose une nouvelle version (et ma réponse serait que... c'est quasi insoluble puisqu'il n'y a pas d'unification à ce niveau pour récupérer l'info directement à la source)...
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [afur] paquets périmés

Message par Xorg » dim. 07 déc. 2014, 20:49

benjarobin a écrit :Personnellement je me suis fait un script pour certain paquet AUR (je ne sais pas s'ils fonctionnent toujours...), ces scripts sont exécutés via cron.
Et en gros le script il télécharge la page web qui contient la version et fait un grep dessus, si la version n'est pas trouvée, j’écris un fichier. Et puis lorsque j'ouvre une console le shell affiche le contenu du fichier s'il existe. C'est très rudimentaire mais cela fonctionne assez bien.
Oui, c'est peut-être rudimentaire mais ce n'est pas du tout bête, je vais y réfléchir, merci. :wink:
FoolEcho a écrit :
benjarobin a écrit :Et en gros le script il télécharge la page web qui contient la version et fait un grep dessus, si la version n'est pas trouvée, j’écris un fichier. Et puis lorsque j'ouvre une console le shell affiche le contenu du fichier s'il existe. C'est très rudimentaire mais cela fonctionne assez bien.
Par contre, sur afur on a recours à AurJson, ce qui permet d'avoir des requêtes et des analyses plus ciblées (et donc pour afur, on stocke dans une table la version sur AUR que l'on compare ensuite pour le tri). :chinois:

Mais je réponds peut-être à côté de la plaque si la question était de savoir comment être informé si un projet donné propose une nouvelle version (et ma réponse serait que... c'est quasi insoluble puisqu'il n'y a pas d'unification à ce niveau pour récupérer l'info directement à la source)...
C'était plutôt ça ma question en effet (je l'ai mal tournée). Hélas oui, c'est fort dommage... Il faut traiter au cas pas cas. :)
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1120
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Re: [afur] paquets périmés

Message par Skunnyk » mer. 10 déc. 2014, 14:09

Depuis que le script de check tourne pour de vrais, on voit qu'il y a quelques périmés.
Je viens d'en supprimer quelques un vraiment vieux (genre plowshare-svn, de 2012, même plus dispo sur AUR…)
Je pense supprimer les périmés depuis trop longtemps (mis à part ceux qui ont "juste" un diff de version de pkgbuild).

D'ailleurs, niveau dropbox, on a pas le droit de fournir le binaire. Debian utilise un wrapper qui va download le dropboxd directement chez dropbox pour respecter la licence. M'est avis qu'il faut enlever le paquet.

De manière générale, il y a du taff à faire sur AFUR, revoir un peu le fonctionnement, et je pense limiter bien plus le type de paquets qu'on peut uploader.

leosw
newbie
Messages : 8
Inscription : mar. 28 janv. 2014, 17:56

Re: [afur] paquets périmés

Message par leosw » mer. 10 déc. 2014, 18:21

Salut,

Est-ce qu'il est possible de mettre à jour QGIS ?
Il ne fait pas partie des logiciels aux mises à jours fréquentes et les numéros pairs sont des version stables (et très longues à compiler via AUR)

Merci ;)

Léo

Avatar de l’utilisateur
coincoin
Daikyu
Messages : 82
Inscription : sam. 12 janv. 2013, 21:19

Re: [afur] paquets périmés

Message par coincoin » sam. 13 déc. 2014, 16:51

Hello,

Juste pour indiquer une mise à jour des paquets scilab, petsc et paraview.
J'ai quelques soucis avec QGIS la version sur afur risque de ne pas marcher je vais revoir ça.

A noter le rajout du paquet libmatio qui est nécessaire pour scilab. Ce qui permet de soulever deux points sur afur :
  • Dans la colonne "Requis par" pour libmatio scilab n'apparaît pas. afur ne peut pas faire de liens entre les paquets dont il dispose ?
  • Le script de comparaison de versionages AUR/Afur ne semble pas fonctionner pour certain cas. libmatio n'a pas de lien vers AUR (ni petsc d'ailleurs).
\_o<

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10533
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [afur] paquets périmés

Message par FoolEcho » sam. 13 déc. 2014, 17:16

coincoin a écrit : A noter le rajout du paquet libmatio qui est nécessaire pour scilab. Ce qui permet de soulever deux points sur afur :
  • Dans la colonne "Requis par" pour libmatio scilab n'apparaît pas. afur ne peut pas faire de liens entre les paquets dont il dispose ?
Oh, il pourrait sans doute, si quelqu'un développait la fonctionnalité dans ce sens (pour le moment, c'est la solution de facilité qui consiste à ne pas faire de vérification de ce niveau car entre ce qui se trouverait sur les dépôts officiels, sur afur et ceux d'AUR, bonjour le casse-tête... :mrgreen: ). :wink:
coincoin a écrit :
  • Le script de comparaison de versionages AUR/Afur ne semble pas fonctionner pour certain cas. libmatio n'a pas de lien vers AUR (ni petsc d'ailleurs).
Comme je l'ai indiqué précédemment, par ce choix de développement le script chargé de vérifier les versions n'est appelé qu'une fois par jour (car c'est le serveur qui l'opère et il n'est pas question qu'il le fasse toutes les 30 secondes + le fait que les paquets ne sont pas mis à jour tous les jours non plus)... Comme tu viens de déposer ces paquets, normal qu'il n'y ait pas de point de comparaison. Vérifie demain à la même heure. :chinois:
Ceci dit, comme il n'y a pas de paquets rajoutés toutes les 5 minutes, il serait probablement envisageable d'en appeler au script à ce moment...
Donc, en l'état, c'est le fonctionnement normal (maintenant si demain à la même heure, ils sont toujours indiqués comme liés à rien, effectivement il y aurait problème mais ça reste à prouver :wink: ).

À ma connaissance, les seuls cas que ne peuvent traiter le script sont les renommages intempestifs de paquets (tant au niveau du nom que du numéro de version forcément, comme ce qui s'est passé avec stapler), pour le reste ça doit coller. En tous cas, je l'ai développé dans ce sens (mais je ne suis pas exempt d'erreurs comme on a pu le constater, à cause d'un effet de bord qui m'avait initialement échappé... :oops: et pas qu'à moi puisque le script a fonctionné un temps en partie sans que personne ne remarque rien :mrgreen: ).
«The following statement is not true. The previous statement is true.» :nage:

viperpaulo
Chu Ko Nu
Messages : 373
Inscription : lun. 06 déc. 2010, 13:58

Re: [afur] paquets périmés

Message par viperpaulo » sam. 13 déc. 2014, 17:49

coincoin a écrit :Hello,

Juste pour indiquer une mise à jour des paquets scilab, petsc et paraview.
J'ai quelques soucis avec QGIS la version sur afur risque de ne pas marcher je vais revoir ça.

A noter le rajout du paquet libmatio qui est nécessaire pour scilab. Ce qui permet de soulever deux points sur afur :
  • Dans la colonne "Requis par" pour libmatio scilab n'apparaît pas. afur ne peut pas faire de liens entre les paquets dont il dispose ?
  • Le script de comparaison de versionages AUR/Afur ne semble pas fonctionner pour certain cas. libmatio n'a pas de lien vers AUR (ni petsc d'ailleurs).
Merci pour cette MàJ et merci pour le boulot !

Avatar de l’utilisateur
coincoin
Daikyu
Messages : 82
Inscription : sam. 12 janv. 2013, 21:19

Re: [afur] paquets périmés

Message par coincoin » dim. 14 déc. 2014, 11:43

Merci pour les précisions FoolEcho, en effet mon deuxième point n'a plus lieu d'être c'est à jour !
Je pense que c'est très bien comme c'est. Ca me paraît beaucoup d'efforts :)

QGis est recompilé et à jour sur Afur.

Est-il possible de supprimer le paquet petsc (any) : http://afur.archlinux.fr/?action=view&p=803 ? Maintenant c'est passé en i686/x86_64. Merci !
\_o<

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10533
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [afur] paquets périmés

Message par FoolEcho » dim. 14 déc. 2014, 12:06

coincoin a écrit :Est-il possible de supprimer le paquet petsc (any) : http://afur.archlinux.fr/?action=view&p=803 ? Maintenant c'est passé en i686/x86_64. Merci !
Fait. :chinois:
«The following statement is not true. The previous statement is true.» :nage:

Répondre