[iucode-tool] échec de la mise à jour (clôturé)

Mise à jour / Création /debug de paquetages
Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1507
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

[iucode-tool] échec de la mise à jour (clôturé)

Message par mimile »

Bonjour,

Ayant entrepris de mettre les paquets AUR à jour (il y en avait une bonne vingtaine), je constate que la mise à jour de iucode-tool échoue.

Illustration :

Image

Le problème provient de la non-reconnaissance de la clef publique FE11BFA68B158E98

Après quelques recherches, je trouve un poste où l'intervenant - qui rencontre le même problème - a exécuté :

Code : Tout sélectionner

sudo pacman-key --refresh-keys
J'en ai fait de même avec un résultat négatif (ci-dessous les dernières lignes) :

Code : Tout sélectionner

gpg: clef A88E23E377514E00 : « Florian Pritz (Arch Linux Master Key) <florian@master-key.archlinux.org> » n'est pas modifiée
gpg:       Quantité totale traitée : 90
gpg:                 non modifiées : 61
gpg:          nouvelles signatures : 711
gpg: [don't know]: invalid packet (ctb=28)
gpg: keyring_get_keyblock: read error: Paquet incorrect
gpg: keydb_get_keyblock failed: Porte-clefs incorrect
gpg: keydb_search failed: Porte-clefs incorrect
gpg: [don't know]: invalid packet (ctb=1c)
gpg: keyring_get_keyblock: read error: Paquet incorrect
gpg: keydb_get_keyblock failed: Porte-clefs incorrect
gpg: keydb_search failed: Porte-clefs incorrect
gpg: skipped packet of type 8 in keyring
gpg: keydb_get_keyblock failed: Erreur système inconnue
gpg: [don't know]: invalid packet (ctb=48)
gpg: keyring_get_keyblock: read error: Paquet incorrect
gpg: keydb_get_keyblock failed: Porte-clefs incorrect
gpg: keydb_search failed: Porte-clefs incorrect
gpg: [don't know]: invalid packet (ctb=09)
gpg: keyring_get_keyblock: read error: Paquet incorrect
gpg: keydb_get_keyblock failed: Porte-clefs incorrect
gpg: keydb_search failed: Porte-clefs incorrect
gpg: [don't know]: invalid packet (ctb=41)
gpg: keyring_get_keyblock: read error: Paquet incorrect
gpg: keydb_get_keyblock failed: Porte-clefs incorrect
gpg: keydb_search failed: Porte-clefs incorrect
gpg: [don't know]: invalid packet (ctb=4b)
gpg: keyring_get_keyblock: read error: Paquet incorrect
gpg: keyring_get_keyblock failed: Porte-clefs incorrect
gpg: échec de reconstruction du cache de porte-clefs : Porte-clefs incorrect
gpg: marginals needed: 3  completes needed: 1  trust model: pgp
gpg: packet(2) too short
gpg: [don't know]: invalid packet (ctb=00)
gpg: keyring_get_keyblock: read error: Paquet incorrect
gpg: keydb_get_keyblock failed: Porte-clefs incorrect
gpg: validate_key_list failed
==> ERREUR : Une clef locale spécifiée n’a pas pu être mise à jour depuis le serveur.
[okapi@Archie Bureau]$ 
Que faire ?

Merci d'avance.
Dernière modification par mimile le jeu. 11 mai 2017, 14:49, modifié 1 fois.
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)
benjarobin
Maître du Kyudo
Messages : 16005
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [iucode-tool] échec de la mise à jour

Message par benjarobin »

Bonjour,
Tout d'abord as tu vraiment besoin de ce paquet (il est assez probable que non...) ?
As tu lu le Wiki sur cette partie ? Car tu confonds la gestion des clés de pacman (qui est fait en root), et les clés publiques de ton utilisateur nécessaire pour construire le paquet :
https://wiki.archlinux.org/index.php/ma ... e_checking
https://wiki.archlinux.org/index.php/Gn ... _keyserver
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1507
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

Re: [iucode-tool] échec de la mise à jour

Message par mimile »

Hello

Mon intérêt pour la mise à jour de iucode-tool résulte du fait qu'il fut une époque où il fallait modifier grub pour éviter un message d'erreur lors du boot (il était question - si j'ai bonne mémoire de fdisck qui ne s'exécutait pas).

Voici un extrait de mon grub (généré par LinuxMint 17 installé en multiple-boot) concernant Arch :

Code : Tout sélectionner

menuentry 'Archlinux (sur /dev/sda5)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-simple-122af965-b8c2-4a6b-bfec-304d66200641' {
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos5'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5  122af965-b8c2-4a6b-bfec-304d66200641
	else
	  search --no-floppy --fs-uuid --set=root 122af965-b8c2-4a6b-bfec-304d66200641
	fi
	linux /boot/vmlinuz-linux root=UUID=122af965-b8c2-4a6b-bfec-304d66200641 rw
	initrd /boot/intel-ucode.img /boot/initramfs-linux.img
}
(seule la dernière ligne suscite mon intérêt en l'occurrence)

A l'époque, il était suggéré d'ajouter "/boot/intel-ucode.img" devant "/boot/initramfs-linux.img" pour éviter ce souci.

Te connaissant - et me connaissant - tu vas probablement me dire que je me plante une fois de plus.

Pourtant, ce que j'ai lu çà et là semble correspondre à mon intérêt pour cette mise à jour.

Quoi qu'il en soit et dans l'attente de tes railleries (je m'y suis fait, avec le temps), je reste ton fidèle auditeur/lecteur

Par ailleurs, si tu avais une solution pour résoudre l'échec de la compilation, je serais évidemment preneur :bravo:

Amicalement,

PS : tu vas probablement m'orienter vers un wiki anglais auquel je ne comprendrai rien (pas que l'anglais me pose problème en soi mais plutôt les mots techniques qui, eux, me sont abolument étrangers).
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)
benjarobin
Maître du Kyudo
Messages : 16005
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [iucode-tool] échec de la mise à jour

Message par benjarobin »

iucode-tool est un outil pour analyser les fichiers Intel microcode tel que intel-ucode.img, mais il ne le fournit pas, c'est le paquet intel-ucode qui le fournit. Donc je te confirme que ce paquet est inutile pour toi et que tu peux sans aucun souci le supprimer.
Et pour être bien clair, oui tu dois garder dans grub.cfg la ligne initrd telle quelle.

Pour faire court et simple pour vérifier l'intégralité d'un fichier dans un PKGBUILD, il y a les hash (md5sum, sha1sum, ...) mais il est possible de rajouter un autre mécanisme de vérification : Les signatures via GnuPG. Pour cela tu doit importer la clé publique pour la stoker dans la configuration de GnuPG de ton utilisateur, car la construction d'un PKGBUILD est fait avec ton utilisateur et non en root.
Pour importer manuellement une clé, il suffit de faire (avec ton utilisateur) :

Code : Tout sélectionner

gpg --recv-key FE11BFA68B158E98 
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1507
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

Re: [iucode-tool] échec de la mise à jour

Message par mimile »

Merci pour ta réponse et ton développement au sujet de la vérification des PKGBUILD.

Mais je dois honnêtement t'avouer que cela me dépasse totalement et ce, à ma grande honte, vu ton préambule "pour faire court et simple ..." :lol:

Je retiens surtout de ta réponse que je peux impunément supprimer iucode-tool.

Cordialement
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)
Répondre