[Dual-Boot W10] Grub ne se lance pas (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
GreenK
newbie
Messages : 4
Inscription : ven. 09 mars 2018, 01:13

[Dual-Boot W10] Grub ne se lance pas (résolu)

Message par GreenK » ven. 09 mars 2018, 01:38

Bien le bonjour amis du jour,
Bien le bonsoir amis du soir,

J'ai un PC portable avec W10 de pré-intallé et je souhaiterais le faire dual-boot avec Arch Linux.

Problème: A la fin de l'installation d'arch-linux (en suivant les wiki fr et eng), mon PC boot automatiquement sur W10 sans passer par une page Grub.

Infos Complémentaires: je souhaite booter en EFI (mon bios est déjà en EFI) et je ne compte pas crypter mes partitions.
Je n'ai pas formaté la partition EFI pour ne pas casser l'armorceur W10.

Déroulé de l'installation:

Mon disque comprend 6 partitions:

Code : Tout sélectionner

Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 0EEEA59B-F568-4AA5-99BF-9EBB042EE4CC

Device          Start        End    Sectors   Size Type
/dev/sda1        2048     206847     204800   100M EFI System
/dev/sda2      206848     239615      32768    16M Microsoft reserved
/dev/sda3      239616  629385216  629145601   300G Microsoft basic data
/dev/sda4   629387264  943960063  314572800   150G Linux filesystem
/dev/sda5   943960064 1951424511 1007464448 480.4G Microsoft basic data
/dev/sda6  1951426560 1953523711    2097152     1G Windows recovery environment
Je souhaite installer Arch sur sda4 et utiliser sda5 comme partition partagée par mes OS.
Je n'ai pas mis de swap.

J'ai bien formaté la partition avec mkfs.ext4, monté /dev/sda4 sur /mnt, installé les packages de base avec pacstrap (base et base-devel) puis généré le fstab que voila.

Code : Tout sélectionner

# Static information about the filesystems.
# See fstab(5) for details.

# <file system> <dir> <type> <options> <dump> <pass>
# /dev/sda4
UUID=e3acbf04-8e03-4977-932b-e280612b40b4	/         	ext4      	rw,relatime,data=ordered	0 1
Ensuite j'ai chrooté, généré mes fichiers de conf pour LANG, KEYMAP etc.. (puis vérifier).
Je n'ai pas installé les packages pour le sans-fils, mais j'ai installé intel-ucode (j'ai un CPU intel).
Même si inutile j'ai exécuté mkinitcpio -p linux puis défini un mot de passe pour root.

Pour le bootloader, j'ai choisi Grub et executé les commandes suivantes

Code : Tout sélectionner

pacman -S grub os-prober efibootmgr mtools
mkdir /boot/EFI
mount /dev/sda1 /boot/EFI
grub-install --target=x86_64-efi --efi-directory=/boot/EFI --bootloader-id=arch
--recheck
grub-mkconfig -o /boot/grub/grub.cfg
Voici le fichier de config en résultant

Code : Tout sélectionner

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
insmod part_gpt
insmod part_msdos
if [ -s $prefix/grubenv ]; then
  load_env
fi
if [ "${next_entry}" ] ; then
   set default="${next_entry}"
   set next_entry=
   save_env next_entry
   set boot_once=true
else
   set default="0"
fi

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_gpt
insmod ext2
set root='hd0,gpt4'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt4' --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4  e3acbf04-8e03-4977-932b-e280612b40b4
else
  search --no-floppy --fs-uuid --set=root e3acbf04-8e03-4977-932b-e280612b40b4
fi
    font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=en_US
  insmod gettext
fi
terminal_input console
terminal_output gfxterm
if [ x$feature_timeout_style = xy ] ; then
  set timeout_style=menu
  set timeout=5
# Fallback normal timeout code in case the timeout_style feature is
# unavailable.
else
  set timeout=5
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Arch Linux' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-e3acbf04-8e03-4977-932b-e280612b40b4' {
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_gpt
	insmod ext2
	set root='hd0,gpt4'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt4' --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4  e3acbf04-8e03-4977-932b-e280612b40b4
	else
	  search --no-floppy --fs-uuid --set=root e3acbf04-8e03-4977-932b-e280612b40b4
	fi
	echo	'Loading Linux linux ...'
	linux	/boot/vmlinuz-linux root=UUID=e3acbf04-8e03-4977-932b-e280612b40b4 rw  quiet
	echo	'Loading initial ramdisk ...'
	initrd  /boot/intel-ucode.img /boot/initramfs-linux.img
}
submenu 'Advanced options for Arch Linux' $menuentry_id_option 'gnulinux-advanced-e3acbf04-8e03-4977-932b-e280612b40b4' {
	menuentry 'Arch Linux, with Linux linux' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-linux-advanced-e3acbf04-8e03-4977-932b-e280612b40b4' {
		load_video
		set gfxpayload=keep
		insmod gzio
		insmod part_gpt
		insmod ext2
		set root='hd0,gpt4'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt4' --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4  e3acbf04-8e03-4977-932b-e280612b40b4
		else
		  search --no-floppy --fs-uuid --set=root e3acbf04-8e03-4977-932b-e280612b40b4
		fi
		echo	'Loading Linux linux ...'
		linux	/boot/vmlinuz-linux root=UUID=e3acbf04-8e03-4977-932b-e280612b40b4 rw  quiet
		echo	'Loading initial ramdisk ...'
		initrd  /boot/intel-ucode.img /boot/initramfs-linux.img
	}
	menuentry 'Arch Linux, with Linux linux (fallback initramfs)' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-linux-fallback-e3acbf04-8e03-4977-932b-e280612b40b4' {
		load_video
		set gfxpayload=keep
		insmod gzio
		insmod part_gpt
		insmod ext2
		set root='hd0,gpt4'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt4' --hint-bios=hd0,gpt4 --hint-efi=hd0,gpt4 --hint-baremetal=ahci0,gpt4  e3acbf04-8e03-4977-932b-e280612b40b4
		else
		  search --no-floppy --fs-uuid --set=root e3acbf04-8e03-4977-932b-e280612b40b4
		fi
		echo	'Loading Linux linux ...'
		linux	/boot/vmlinuz-linux root=UUID=e3acbf04-8e03-4977-932b-e280612b40b4 rw  quiet
		echo	'Loading initial ramdisk ...'
		initrd  /boot/intel-ucode.img /boot/initramfs-linux-fallback.img
	}
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###
Puis j'ai déchrooté, démonté, redémarré mon PC et ....W10!
Les différentes commandes ne m'ont pas retourné d'erreurs ni de warnings inquétiants. Je pense que je me suis trompé dans l'installation de mon armorceur ce pourquoi j'ai plus détaillé la partie associée.
Je ne vois pas W10 dans le grub.cfg.
Any ideas?

Merci d'avance :D
Dernière modification par GreenK le mar. 13 mars 2018, 00:14, modifié 1 fois.

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1999
Inscription : jeu. 15 mars 2012, 05:08

Re: [Dual-Boot W10] Grub ne se lance pas

Message par waitnsea » ven. 09 mars 2018, 07:17

GreenK a écrit :
ven. 09 mars 2018, 01:38
Pour le bootloader, j'ai choisi Grub et executé les commandes suivantes

Code : Tout sélectionner

pacman -S grub os-prober efibootmgr mtools
mkdir /boot/EFI
mount /dev/sda1 /boot/EFI
grub-install --target=x86_64-efi --efi-directory=/boot/EFI --bootloader-id=arch
--recheck
grub-mkconfig -o /boot/grub/grub.cfg
Bonjour,
Dans la partie Installation de GRUB, dans la commande # grub-install --target=x86_64-efi --efi-directory=esp --bootloader-id=arch
esp est en italique pour signifier le montage, donc /boot/efi et non '''EFI''' qui est un répertoire que tu y crées, ou qui y a été créé par Windows, pour, après utiliser la bonne commande :

Code : Tout sélectionner

# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=arch --recheck
qui installera le dossier arch (+ d'autres distros éventuelles) dans /boot/efi/EFI/
Puis tu lanceras efibootmgr ainsi

Code : Tout sélectionner

• Contrôle et liste :
# efibootmgr
# efibootmgr -v

• voir l'ordre de boot courant :
$ efibootmgr | grep BootOrder

• savoir à quelle entrée correspond chaque nombre :
$ efibootmgr | grep Boot0

• changer l'ordre de boot :
classer ces valeurs en hexadécimal de sorte qu'en premier vous écrirez le premier ordre de boot (c'est-à-dire le premier périphérique sur lequel l'UEFI tentera de démarrer) 
et en dernier le dernier ordre de boot :
# efibootmgr -o XXXX,YYYY,ZZZZ
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

GreenK
newbie
Messages : 4
Inscription : ven. 09 mars 2018, 01:13

Re: [Dual-Boot W10] Grub ne se lance pas

Message par GreenK » ven. 09 mars 2018, 08:25

Hey waitnsea,
Merci pour ta réponse.

Je ne suis pas sûr de comprendre. D'après le tuto "esp" renvoie vers le lieu de montage de la partition EFI (/dev/sda1 pour moi) qui est "/boot/EFI" pour moi. (j'ai mis EFI en maj par mégarde mais ce n'est pas ça le problème, ..si?)

Sinon mon dosser /boot/EFI/EFI contient bien 3 sous-dossiers (une fois /dev/sda1 montée en /boot/EFI): arch, Boot et Microcrosft.

La commande efibootmgr me retourne la configuration suivante:

Code : Tout sélectionner

BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0000,2001,0002,2002,2003
Boot0000* arch	HD(1,GPT,4b29be4c-12f6-43ae-8047-af77f64012b2,0x800,0x32000)/File(\EFI\arch\grubx64.efi)
Boot0001* USB HDD: USB DISK 2.0	PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/HD(1,MBR,0x610aca7c,0xa4,0x20000)RC
Boot0002* Windows Boot Manager	HD(1,GPT,4b29be4c-12f6-43ae-8047-af77f64012b2,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...4................
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot2003* EFI Network	RC
Les entrées de 00001 à la fin correspondent bien à l'ordre de boot d'avant installation. Un mode de boot "arch" s'est bien ajouté à la liste.
J'ai refait un grub-mkconfig. Pas d'amélioration en redémarrant le PC.

benjarobin
Maître du Kyudo
Messages : 15531
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Dual-Boot W10] Grub ne se lance pas

Message par benjarobin » ven. 09 mars 2018, 09:08

EFI n'aurait pas dû être en majuscule, mais ce n'est pas grave (et cela se corrige très simplement) et ce n'est pas du tout l'origine du problème.

La commande efibootmgr a été lancé après un redémarrage ? Ou directement après une installation de Grub ?
Peux tu redonner la sortie de cette commande directement depuis le CD d'installation après avoir éteint le PC.

Je soupçonne un problème avec le firmware de ta carte mère (comme malheureusement beaucoup de carte mère)
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

GreenK
newbie
Messages : 4
Inscription : ven. 09 mars 2018, 01:13

Re: [Dual-Boot W10] Grub ne se lance pas

Message par GreenK » ven. 09 mars 2018, 19:02

Tout d'abord merci pour le temps que vous me consacrez.
J'ai relancé la commande en bootant sur la clé et j obtiens la même chose à une différence près: le BootOrder.

Celui que j'obtiens est: 2001,0002,2002,2003.

J'ai essayé de remettre le boot en mode sécurisé comme conseiller dans certains posts qui trainent sur le forum acer (la marque de mon pc) mais sans succès.

GreenK
newbie
Messages : 4
Inscription : ven. 09 mars 2018, 01:13

Re: [Dual-Boot W10] Grub ne se lance pas (solved)

Message par GreenK » lun. 12 mars 2018, 21:20

Une bonne et une mauvaise nouvelles.

la bonne: Je sais lancer GRUB. J'ai suivi les indications du lien suivant: https://askubuntu.com/questions/627416/ ... -dual-boot (en selection l'efi présente dans le dossier arch).

La mauvaise: Seulement Arch est visible depuis GRUB. Mais je crois que c'est un pb déjà traité dans des posts précédents sur ce forum donc je vais mener mon enquète.

Keep you in touch

EDIT: problème solved. Grub est case-sensitve et je devais bien mettre /boot/efi/EFI et non /boot/EFI/EFI

Tout fonctionne. Topic validé.
Merci
(et à très bientôt pour de nouvelles aventures..)

Répondre