[Installation] Bug interférences/grésillements audio [Résolu]

Questions et astuces concernant l'installation et la configuration d'archlinux
libraemy
newbie
Messages : 4
Inscription : jeu. 03 janv. 2019, 14:15

[Installation] Bug interférences/grésillements audio [Résolu]

Message par libraemy » jeu. 03 janv. 2019, 14:40

Bonjour à tous,

Je suis un nouvel utilisateur de Linux et mon choix s'est porté sur une distribution Arch en vue d'apprendre le fonctionnement du système d'exploitation d'un peu plus près. J'ai donc décidé de donner une nouvelle jeunesse à un ordinateur portable HP-DV7 de 2011 (https://support.hp.com/fr-fr/product/HP ... el/5141816) et je travaille dessus depuis plusieurs semaines à présent.

Je résous progressivement tous les problèmes d'installation uns par uns, tout en comprenant davantage le fonctionnement sous Linux, mais voila, je sèche complètement sur ce petit "bug" qui a le don de m'exaspérer au plus haut point. Il est d'ailleurs assez difficile à décrire, mais pour être le plus précis possible, dès que l'ordinateur ouvre un programme pour le première fois et se met à charger, il émet au niveau des hauts-parleurs (en tout cas il me semble) des espèces de craquements bizarres qui rappellent un peu ceux d'une tête de lecture sur un HDD. Hors le seul disque dur branché est un SSD et je ne comprends pas pourquoi celui-ci émettrait ce type de bruit...

Pour être plus précis, voici un exemple vidéo du problème : https://vimeo.com/309283991
Ce que vous pouvez voir ici, c'est le premier lancement de firefox après un redémarrage. Vous entendez clairement ces espèces de craquements lors de la mise en mémoire. Mais une fois la session ouverte, et si je m'amuse à fermer et re-ouvrir firefox, plus de soucis.

Les "interférences audio" interviennent dès le processus de boot, juste après Grub il me semble et surtout dès le lancement de Xorg et de mon interface graphique. Ensuite à l'utilisation, le PC fait ces mêmes étranges bruits lorsqu'il exécute certaines taches.

A noter également que je n'ai jamais entendu ces bruits sous Windows. J'ai essayé l'installation sur un autre disque dur SSD et le problème est le même.

Bref, je ne sais pas quoi faire et je ne sais même pas dans quelle direction chercher afin de résoudre ce désagrément !
Un coup de pouce serait vraiment grandement apprécié ! Merci :D
Dernière modification par libraemy le ven. 04 janv. 2019, 21:30, modifié 2 fois.

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10528
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Installation] Bug interférences/grésillements audio

Message par FoolEcho » ven. 04 janv. 2019, 09:20

Salut,

A priori, ça semble bien un problème audio... Essaie peut-être de brancher un casque audio: si tu entends encore le bruit le problème se situerait au niveau de la carte son (à voir si elle demande un pilote particulier), sinon ce serait vraisemblablement les haut-parleurs qui auraient un souci (et sur un portable c'est la m... car pas trop à désosser).
«The following statement is not true. The previous statement is true.» :nage:

libraemy
newbie
Messages : 4
Inscription : jeu. 03 janv. 2019, 14:15

Re: [Installation] Bug interférences/grésillements audio

Message par libraemy » ven. 04 janv. 2019, 14:07

FoolEcho a écrit :
ven. 04 janv. 2019, 09:20
Salut,

A priori, ça semble bien un problème audio... Essaie peut-être de brancher un casque audio: si tu entends encore le bruit le problème se situerait au niveau de la carte son (à voir si elle demande un pilote particulier), sinon ce serait vraisemblablement les haut-parleurs qui auraient un souci (et sur un portable c'est la m... car pas trop à désosser).
Merci pour ta réponse. J'avais oublié de préciser dans mon premier message, j'avais déjà essayé avec un casque et le problème est similaire. Le bruit n'est perceptible que depuis les hauts parleurs du PC mais pas dans le casque. Je commence à me demander si cela ne viendrait pas de la barre de son sous l'écran, ou du système Beats Audio qui était vendu avec ce portable...

Je vais essayer de le démonter, ce n'est pas la première fois que j'ai eu à le désosser :)

libraemy
newbie
Messages : 4
Inscription : jeu. 03 janv. 2019, 14:15

Re: [Installation] Bug interférences/grésillements audio

Message par libraemy » ven. 04 janv. 2019, 16:16

Je viens de trouver la source du problème en démontant le PC. Il s'agit d'un bug avec le front speaker (la barre sous l'écran) qui ne cause plus ce problème une fois débranchée de la carte mère. Le son du PC marche encore, mais uniquement depuis les deux enceintes de devant. J'avais installé respectivement alsa-mixer puis pulse audio et dans tous les cas le problème de compabilité était présent. Si quelqu'un a une idée afin de faire marcher toutes ces enceintes ensembles, je suis preneur ! Reste qu'en attendant, il suffit de débrancher la moitié des enceintes pour avoir la paix... Pas très élégant, mais efficace !

libraemy
newbie
Messages : 4
Inscription : jeu. 03 janv. 2019, 14:15

Re: [Installation] Bug interférences/grésillements audio

Message par libraemy » ven. 04 janv. 2019, 21:29

Problème complètement résolu à présent. Il s'agit bien d'un bug avec Beats audio qui peut être règlé avec hdajackretask. Pour ceux que cela intéressera, voici la solution que j'ai suivie : https://www.reddit.com/r/linux/comments ... eakers_on/

Répondre