[Wifi] Problème connexion wifi

Applications, problèmes de configuration réseau
Maxime_
newbie
Messages : 8
Inscription : dim. 20 mai 2018, 16:55

[Wifi] Problème connexion wifi

Message par Maxime_ » dim. 28 avr. 2019, 18:11

Bonjour,
J'ai un nouvel ordinateur avec arch et deepinDE. Mon wifi est très instable:

Il m'est impossible de me connecter au wifi de mon école bien que je sois sûr à 100% que les infos rentrées sont correctes (j'ai un autre arch+deepinDE qui se connecte très bien).
De plus sur mon wifi personnel j'ai fréquemment des pertes de connexion et il m'est ensuite impossible de me reconnecter (Deepin me dit "mauvais mot de passe").
J'ai plusieurs pistes mais rien que je puisse régler seul.
Premièrement lorsque je me connecte sur le partage de donnée de mon téléphone, le nom de mon ordinateur est "*" or j'ai renseigné /etc/hostname avec "max-laptop" lors de l'installation d'arch.
Ensuite il est possible que plusieurs pilots wireless interfèrent.

Malheureusement je ne sais pas vraiment quoi vous fournir de plus comme information.
Si vous pouviez m'aider ça serait génial.
Merci d'avance et n'hésitez pas à me demander de poster le résultat de commandes, je suis à votre entière disposition.

Cordialement,
Max

laurent85
Chu Ko Nu
Messages : 312
Inscription : mar. 16 oct. 2018, 21:05

Re: [Wifi] Problème connexion wifi

Message par laurent85 » dim. 28 avr. 2019, 19:58

Bonjour,
Donne les détails du matériel, que renvoie cette commande :

Code : Tout sélectionner

lspci -nnv | awk -v IGNORECASE=1 -v RS= '/network controller|wireless/'

Maxime_
newbie
Messages : 8
Inscription : dim. 20 mai 2018, 16:55

Re: [Wifi] Problème connexion wifi

Message par Maxime_ » dim. 28 avr. 2019, 20:07

Merci pour votre réponse

Code : Tout sélectionner

~ sudo lspci -nnv | awk -v IGNORECASE=1 -v  RS= '/network controller|wireless/'
02:00.0 Network controller [0280]: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter [168c:0042] (rev 31)
	Subsystem: Dell QCA9377 802.11ac Wireless Network Adapter [1028:1810]
	Flags: bus master, fast devsel, latency 0, IRQ 138
	Memory at c1000000 (64-bit, non-prefetchable) [size=2M]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable+ Count=1/8 Maskable+ 64bit-
	Capabilities: [70] Express Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [148] Virtual Channel
	Capabilities: [168] Device Serial Number 00-00-00-00-00-00-00-00
	Capabilities: [178] Latency Tolerance Reporting
	Capabilities: [180] L1 PM Substates
	Kernel driver in use: ath10k_pci
	Kernel modules: ath10k_pci
Par ailleurs, voici la page où j'ai acheté l'ordinateur: https://www.ldlc.com/fiche/PB00266801.html

laurent85
Chu Ko Nu
Messages : 312
Inscription : mar. 16 oct. 2018, 21:05

Re: [Wifi] Problème connexion wifi

Message par laurent85 » dim. 28 avr. 2019, 22:58

Essai d'utiliser le pilote avec cette option, redémarre ensuite :

Code : Tout sélectionner

echo "options ath10k_core skip_otp=1" | sudo tee /etc/modprobe.d/ath10k_core.conf
Il est possible aussi que certains protocoles wifi posent problème avec ce pilote, dont celui configuré et utilisé par le point d'accès de l'école que tu ne peux pas changer. Avec le modèle de la puce wifi QCA9377 en faisant des recherches tu trouveras peut-être mieux que ce que j'ai trouvé. Il semble qu'avec la série 5 du noyau Linux cette puce wifi fonctionne correctement pour certains.

Maxime_
newbie
Messages : 8
Inscription : dim. 20 mai 2018, 16:55

Re: [Wifi] Problème connexion wifi

Message par Maxime_ » lun. 29 avr. 2019, 09:39

Cette option était mise à "y" initialement.
Ce matin je note une amélioration, si elle est constante je passe en résolu.

Merci :)

Répondre