[ath10k] spamme journalctl (Résolu)

Applications, problèmes de configuration réseau
Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1999
Inscription : jeu. 15 mars 2012, 05:08

[ath10k] spamme journalctl (Résolu)

Message par waitnsea » dim. 23 juin 2019, 10:47

Bonjour,
Bien que je sois connecté en filaire, je garde ma carte wifi en fonction pour l'imprimante.
Ma carte réseau est

Code : Tout sélectionner

$ lspci -knn|grep -iA2 net  
Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 20)
Subsystem: Lenovo QCA6174 802.11ac Wireless Network Adapter [17aa:3044]
Kernel driver in use: ath10k_pci
Kernel modules: ath10k_pci
Elle fonctionne bien, en wifi comme en bluetooth, mais emplit journalctl de ces erreurs en boucle :

Code : Tout sélectionner

juin 23 10:35:55 lenovo kernel: ath10k_pci 0000:03:00.0: failed to parse tlv: -22
juin 23 10:35:55 lenovo kernel: ath10k_pci 0000:03:00.0: failed to parse chan info event: -22
juin 23 10:35:55 lenovo kernel: ath10k_pci 0000:03:00.0: failed to parse tlv: -22
juin 23 10:35:55 lenovo kernel: ath10k_pci 0000:03:00.0: failed to parse chan info event: -22
...
=>

Code : Tout sélectionner

$ journalctl -b |rg failed |wc -l           
6691
$ journalctl |rg failed |wc -l                                                         
125786
... déplaisant.
Atheros & ath10k sont des sources de soucis connues, mais si j'essaie de remplacer les libs de linux-firmware par celles du paquet le plus récent de kvalo je n'ai plus de wifi...
Une idée pour au moins bloquer les messages ?
Merci d'avance
Dernière modification par waitnsea le mar. 08 oct. 2019, 06:33, modifié 4 fois.
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

benjarobin
Maître du Kyudo
Messages : 15532
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [ath10k] remplit d'erreurs journalctl

Message par benjarobin » dim. 23 juin 2019, 12:18

Bonjour,
Ce qui est sûr c'est que tu n'es pas tout seul : https://bugzilla.kernel.org/show_bug.cgi?id=202849
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1999
Inscription : jeu. 15 mars 2012, 05:08

Re: [ath10k] remplit d'erreurs journalctl (persiste)

Message par waitnsea » dim. 23 juin 2019, 12:44

benjarobin a écrit :
dim. 23 juin 2019, 12:18
Bonjour,
Ce qui est sûr c'est que tu n'es pas tout seul : https://bugzilla.kernel.org/show_bug.cgi?id=202849
Merci benjarobin,

Code : Tout sélectionner

$ journalctl --reverse |rg failed |rg ath10k
juin 17 16:41:15 lenovo kernel: ath10k_pci 0000:03:00.0: failed to parse tlv: -22
donc malgré le nombre impressionnant de lignes, ça n'aurait commencé que le 17 juin ! Bon espoir donc que ce soit corrigé bientôt...

Edit : sur le noyau lts ça ne se produit pas, donc merci de m'avoir aiguillé sur un pb de noyau et non de pilote
Edit 2 : Persistance du problème avec le nouveau noyau 5.1.14
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

laurent85
Chu Ko Nu
Messages : 359
Inscription : mar. 16 oct. 2018, 21:05

Re: [ath10k] remplit d'erreurs journalctl

Message par laurent85 » lun. 24 juin 2019, 17:46

Bonjour,
waitnsea a écrit :
dim. 23 juin 2019, 10:47
Une idée pour au moins bloquer les messages ?
Les bloquer non mais tu peux jouer sur le flot de messages en modifiant ces valeurs dans /etc/systemd/journald.conf :

Code : Tout sélectionner

RateLimitIntervalSec=30s
RateLimitBurst=10000

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1999
Inscription : jeu. 15 mars 2012, 05:08

Re: [ath10k] remplit d'erreurs journalctl

Message par waitnsea » lun. 24 juin 2019, 19:02

laurent85 a écrit :
lun. 24 juin 2019, 17:46
tu peux jouer sur le flot de messages en modifiant ces valeurs dans /etc/systemd/journald.conf :

Code : Tout sélectionner

RateLimitIntervalSec=30s
RateLimitBurst=10000
Merci,
Pour l'instant je roule sur linux-lts, et, depuis, retour nul de journalctl -b |rg failed |rg ath10k, il s'agit donc bien d'un bug kernel...
le premier update de linux linux n'a rien changé, j'attends le suivant...

Mais je n'ai peut-être pas bien compris une manip précédente, j'avais réglé

Code : Tout sélectionner

SystemMaxUse=200M
SystemMaxFileSize=50M
et j'ai pourtant malgré cela, "grâce" à ce bug :

Code : Tout sélectionner

du -sh /var/log/journal
225M    /var/log/journal
Bon, il n'y a pas un monde de différence, je vais surveiller
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1999
Inscription : jeu. 15 mars 2012, 05:08

Re: [ath10k] remplit d'erreurs journalctl (persiste)

Message par waitnsea » lun. 01 juil. 2019, 08:50

Le problème de spam du journalctl persiste malgré 3 nouvelles versions successives du noyau linux et la dernière version (Testing) de linux-firmware, je suis obligé de rester sur le noyau linux-lts si je veux garder un journalctl utilisable...
La page https://bugzilla.kernel.org/show_bug.cgi?id=202849 est d'un silence assourdissant et je n'ai pas envie de remplacer une carte Wifi ac/bluetooth qui fonctionne bien pour ça...
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1999
Inscription : jeu. 15 mars 2012, 05:08

Re: [ath10k] remplit d'erreurs journalctl (contourné)

Message par waitnsea » lun. 08 juil. 2019, 14:22

Actuellement nous en sommes au noyau 5.1.16 avec le même problème (qui n'existe toujours pas avec le noyau LTS)
Comme, d'après le rapport de bug le spam semblait venir de l'ACS (Sélection automatique de canal wifi), j'ai essayé de désactiver NetworkManager, remplacé par systemd-networkd, en enlevant bien sûr, étant sous KDE, nm-applet
Au boot j'ai une salve de 4 erreurs :

Code : Tout sélectionner

$ journalctl -b |rg failed |rg ath10k  
juil. 08 13:57:21 lenovo kernel: ath10k_pci 0000:03:00.0: failed to parse tlv: -22
juil. 08 13:57:21 lenovo kernel: ath10k_pci 0000:03:00.0: failed to parse chan info event: -22
juil. 08 13:57:21 lenovo kernel: ath10k_pci 0000:03:00.0: failed to parse tlv: -22
juil. 08 13:57:21 lenovo kernel: ath10k_pci 0000:03:00.0: failed to parse chan info event: -22
mais qui s'arrêtent ensuite, le spam continu a cessé.
Je verrai quand on sera au noyau 5.20...
Edit: toujours présent avec le noyau 5.2.1.arch1-1... mais absent en bootant sur le 4.19.60-1-lts

EDIT Final : les messages ont disparu avec le passage au noyau 5.3.4
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Répondre