[xorg] qwerty au reboot

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
_alexmyself
Chu Ko Nu
Messages : 405
Inscription : lun. 18 sept. 2006, 16:21
Localisation : france, yvelines 78

[xorg] qwerty au reboot

Message par _alexmyself »

désolé pour le titre du thread mais je galère un tant soit peu avec mon nouveau clavier qwerty sous x.

le soucis c'est que j'ai "autodetect" false dans mon xorg.conf
il y a eu la maj et hop adieu clavier fr.
c'est pénible et en plus je ne sait pas ou aller modifier.

sous console c'est ok.
x c est vraiment le truc a tuer.....

....putain ca m'énerve....
Dernière modification par _alexmyself le dim. 15 févr. 2009, 19:01, modifié 1 fois.
Avatar de l’utilisateur
aldevar
archer de cavalerie
Messages : 172
Inscription : sam. 25 nov. 2006, 10:55
Localisation : Cote d'armor

Message par aldevar »

Salut,

Dans un premier temps, pour pouvoir utiliser un mappage fr du clavier, tu peux lancer, dans un terminal :

Code : Tout sélectionner

$ setxkbmap fr
Ça te permettra déjà de pouvoir modifier tes fichiers.

Perso, voici ce que j'ai dans mon xorg.conf

Code : Tout sélectionner

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "CoreKeyboard"
	Option	    "XkbRules" "xorg"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "fr"
	Option	    "XkbVariant" ""
EndSection
J'en profite pour poser une question. Est-ce bien dans l'option Xkbvariant qu'il faut mettre l'option "oss" pour avoir un 'vrai' clavier français ?
Avatar de l’utilisateur
chipster
Maître du Kyudo
Messages : 2063
Inscription : ven. 11 août 2006, 22:25
Localisation : Saint-Étienne (42)
Contact :

Re: maj , qwerty au reboot sous x

Message par chipster »

_alexmyself a écrit :desole pour le titre du thread mais je galere un tant soit peu avec ;on nouveau clavier qwerty sous x.

le soucis c est que j ai $autodetect$ false dans mon xorg<conf
il y a eu la ;aj et hop adieu clavier fr<
c est peniblem et en plus je ne sait pas ou aller ;odifier<

sous console c est ok<
x c est vrai;ent le truc a tuer<<<<

....putain ca ; enerve....
Depuis le temps que tu es ici, il faudrait que tu t'appliques à faire un topic digne de ce nom, tu ne crois pas ?
Avatar de l’utilisateur
marc[i1]
Maître du Kyudo
Messages : 1753
Inscription : ven. 27 oct. 2006, 10:48
Localisation : Nantes (44)
Contact :

Re: maj , qwerty au reboot sous x

Message par marc[i1] »

_alexmyself a écrit :desole pour le titre du thread mais je galere un tant soit peu avec ;on nouveau clavier qwerty sous x.
J'ai eu le même cas aussi.

Code : Tout sélectionner

/etc/hal/fdi/policy/10-keymap.fdi
avait disparu ! :shock:

La mise à jour de libx11 supprime libx11-bepo et lors du remplacement 10-keymap.fdi a dû être supprimé, je ne vois que ça comme explication chez moi, tu avais aussi la libx11-bepo installé ?

Il faut juste le recopier, c'est con mais c'est pas bien grave ^^
Ne vous emmerdez plus, emmerdez les autres.
_alexmyself
Chu Ko Nu
Messages : 405
Inscription : lun. 18 sept. 2006, 16:21
Localisation : france, yvelines 78

Message par _alexmyself »

merci pour vos réponses.

j'ai sensiblement cette conf pour mon clavier dans xorg.conf, et elle a toujours fonctionnée a merveille.

j'ai réinstallé/relancé hal.

et au final je pige pas grand chose, ça a l'air folklorique comme souçi.
le fait d'être user/root change les réactions, et xfce/kde ça change aussi.
des fois je récupère tout, genre là je peut taper sous user/kde/ff en français, mais sous xfce niet, ff est qwerty, et pas sous root et.. et... bref faut que je parvienne a cerner un peu les choses là....

j'ai encore trop rien cherché, hier quand j'ai vu ça je suis venu poster ici direct pensant que tout le monde allait avoir le même souçis..

je vais regarder un peu plus avant tout ça.

@chipster: il était très beau ce topic, taggé 2h38 du mat et dont le contenu transpirait parfaitement l'angoisse du moment, de l'art conceptuel même! :D :D
Avatar de l’utilisateur
wido
Chu Ko Nu
Messages : 497
Inscription : mar. 21 oct. 2008, 20:59

Message par wido »

Salut, j'ai le même problème que alex,
je n'ai plus de

Code : Tout sélectionner

/etc/hal/fdi/policy/10-keymap.fdi
comment vous faites pour le ravoir?
c'est au login du gdm que mon clavier est en qwerty le reste est en français
je n 'avais pas envie de faire un autre post :snifff:

EDIT :

Code : Tout sélectionner

cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy/
merci :lol:
Image
Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Message par mélodie »

Bonjour,
Moi aussi ce matin... je viens de faire un setxkbmap fr, de refermer Firefox, et de le relancer, parce que juste avant, j'ai dû préparer un post sur un éditeur de textes. :-(

Le voici:

Sqlut,

chew ;oi qussi .- le clqvier est en qwerty ce ;qtinq< bqh 9q resse;ble 0 rien hein M

Traduction:

Salut,

Chez moi aussi : le clavier est en qwerty ce matin. Bah ça ressemble à rien hein ?

Cela ne se produit apparemment que dans les applications qui ont été lancées avant que je ne lance en console
setxkbmap fr.

Donc là j'écris sur Geany, et dans ma console, tout comme alexmyself, c'était bien en azerty après avoir démarré X.

Je n'utilise pas hal et evdev, mon xorg.conf est ainsi fait:
Section "InputDevice"
Identifier "Keyboard0"
# Driver "keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr-latin9"
# Option "XkbVariant" ""
EndSection
Je viens juste de commenter la ligne

Code : Tout sélectionner

#	Driver      "keyboard"
et d'ajouter la ligne

Code : Tout sélectionner

	Driver	    "kbd"

Je vais relancer X et voir si ça aide.

/j'ai relancé X et ça n'a rien changé. :-(

Autrement j'ai bien aussi
Section "ServerFlags"
Option "AllowMouseOpenFail" "true"
Option "AutoAddDevices" "False"

EndSection
Quand aux mises à jour hier je n'en ai une qu'une : bogofilter, pour les spams avec le courriéleur Sylpheed,
et l'installation de xmoto fontmatrix et quelques fontes.
extrait du log de pacman:
[2009-02-15 01:06] synchronizing package lists
[2009-02-15 01:07] starting full system upgrade
[2009-02-15 01:07] starting full system upgrade
[2009-02-15 01:07] upgraded bogofilter (1.1.7-2 -> 1.1.7-3)
[2009-02-15 15:47] synchronizing package lists
[2009-02-15 15:47] starting full system upgrade
[2009-02-15 15:53] installed libmikmod (3.1.12-2)
[2009-02-15 15:53] installed smpeg (0.4.4-5)
[2009-02-15 15:53] installed sdl_mixer (1.2.8-3)
[2009-02-15 15:53] installed ode (0.11-1)
[2009-02-15 15:53] installed sdl_ttf (2.0.9-1)
[2009-02-15 15:53] installed sdl_net (1.2.7-2)
[2009-02-15 15:53] installed xmoto (0.5.0-2)
[2009-02-15 20:49] Updating font cache... done.
[2009-02-15 20:49] installed artwiz-fonts (1.3-3)
[2009-02-15 20:50] Updating font cache... done.
[2009-02-15 20:50] installed font-misc-meltho (1.0.0-4)
[2009-02-15 21:14] installed fontmatrix (0.4.2-2)
Hier le clavier ne me posait aucun souci, et avant-hier j'ai eu ça comme mises à jour:
[2009-02-14 13:19] synchronizing package lists
[2009-02-14 13:19] starting full system upgrade
[2009-02-14 13:32] starting full system upgrade
[2009-02-14 13:45] upgraded libtasn1 (1.7-1 -> 1.8-1)
[2009-02-14 13:45] upgraded gnutls (2.6.3-1 -> 2.6.4-1)
[2009-02-14 13:45] upgraded xcb-proto (1.2-2 -> 1.3-1)
[2009-02-14 13:45] upgraded libxcb (1.1.90.1-1 -> 1.1.93-1)
[2009-02-14 13:45] upgraded libx11 (1.1.5-2 -> 1.1.99.2-2)
[2009-02-14 13:45] upgraded inputproto (1.4.4-1 -> 1.5.0-1)
[2009-02-14 13:45] upgraded xextproto (7.0.4-1 -> 7.0.5-1)
[2009-02-14 13:45] upgraded libxext (1.0.4-1 -> 1.0.5-1)
[2009-02-14 13:45] upgraded ghostscript (8.64-1 -> 8.64-2)
[2009-02-14 13:45] >>> Updating module dependencies. Please wait ...
[2009-02-14 13:45] >>> MKINITCPIO SETUP
[2009-02-14 13:45] >>> ----------------
[2009-02-14 13:45] >>> If you use LVM2, Encrypted root or software RAID,
[2009-02-14 13:45] >>> Ensure you enable support in /etc/mkinitcpio.conf .
...
[2009-02-14 13:45] ==> Building image "default"
[2009-02-14 13:45] ==> Running command: /sbin/mkinitcpio -k 2.6.28-ARCH -c /etc/mkinitcpio.conf -g /boot/kernel26.img
[2009-02-14 13:45] :: Begin dry run
[2009-02-14 13:45] :: Parsing hook [base]
...
[2009-02-14 13:46] :: Parsing hook [filesystems]
[2009-02-14 13:46] :: Generating module dependencies
[2009-02-14 13:46] :: Generating image '/boot/kernel26.img'...SUCCESS
[2009-02-14 13:46] ==> SUCCESS
[2009-02-14 13:46] ==> Building image "fallback"
[2009-02-14 13:46] ==> Running command: /sbin/mkinitcpio -k 2.6.28-ARCH -c /etc/mkinitcpio.conf -g /boot/kernel26-fallback.img -S autodetect
[2009-02-14 13:46] :: Begin dry run
[2009-02-14 13:46] :: Parsing hook [base]
....
[2009-02-14 13:47] :: Parsing hook [filesystems]
[2009-02-14 13:47] :: Generating module dependencies
[2009-02-14 13:47] :: Generating image '/boot/kernel26-fallback.img'...SUCCESS
[2009-02-14 13:47] ==> SUCCESS
[2009-02-14 13:47] upgraded kernel26 (2.6.28.4-1 -> 2.6.28.5-1)
[2009-02-14 13:47] upgraded libice (1.0.4-1 -> 1.0.5-1)
[2009-02-14 13:47] upgraded libxi (1.1.4-1 -> 1.2.0-1)
[2009-02-14 13:47] upgraded pixman (0.12.0-1 -> 0.14.0-1)
[2009-02-14 13:47] upgraded xcb-util (0.3.2-1 -> 0.3.3-1)
[2009-02-14 13:47] upgraded xf86-input-evdev (2.1.0-1 -> 2.1.2-1)
[2009-02-14 13:47] upgraded xf86-input-keyboard (1.3.1-1 -> 1.3.2-1)
[2009-02-14 13:47] upgraded xkeyboard-config (1.4-2 -> 1.5-1)
[2009-02-14 13:47] upgraded xorg-xinit (1.1.0-1 -> 1.1.1-1)
[2009-02-14 13:47] upgraded xterm (239-1 -> 241-1)
Une autre chose curieuse, alors que avant-hier l'ajout de ck-launch-session entre exec et startlxde
avait résolu le shutdown et reboot en mode graphique, hier soir à nouveau ça ne fonctionnait plus.
Sujet traité là:
http://forums.archlinux.fr/topic3143.html?highlight=

Je ne sais pas quoi chercher au juste, et où.

Merci par avance pour vos avis.
Dernière modification par mélodie le lun. 16 févr. 2009, 17:37, modifié 1 fois.
Avatar de l’utilisateur
marc[i1]
Maître du Kyudo
Messages : 1753
Inscription : ven. 27 oct. 2006, 10:48
Localisation : Nantes (44)
Contact :

Message par marc[i1] »

Le problème est aussi référencé sur bbs.

essaie de revenir avec la version précédente de :

Code : Tout sélectionner

[2009-02-14 13:47] upgraded xf86-input-evdev (2.1.0-1 -> 2.1.2-1)
[2009-02-14 13:47] upgraded xf86-input-keyboard (1.3.1-1 -> 1.3.2-1)
[2009-02-14 13:47] upgraded xkeyboard-config (1.4-2 -> 1.5-1) 
amha le problème vient d'un de ces paquetages !

Faudrait voir le diff du contenu de ces paquetages si possible.
Ne vous emmerdez plus, emmerdez les autres.
annaellevera
Daikyu
Messages : 52
Inscription : ven. 06 juin 2008, 09:19

Message par annaellevera »

wido a écrit :
EDIT :

Code : Tout sélectionner

cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy/
merci :lol:
Ca fonctionne mais attention de modifier a ligne :

Code : Tout sélectionner

<merge key="input.xkb.layout" type="string">us</merge>
en :

Code : Tout sélectionner

<merge key="input.xkb.layout" type="string">fr</merge>
Image

World will end in 5 minutes. Please log out.
Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Message par mélodie »

marc[i1] a écrit : essaie de revenir avec la version précédente de :

Code : Tout sélectionner

[2009-02-14 13:47] upgraded xf86-input-evdev (2.1.0-1 -> 2.1.2-1)
[2009-02-14 13:47] upgraded xf86-input-keyboard (1.3.1-1 -> 1.3.2-1)
[2009-02-14 13:47] upgraded xkeyboard-config (1.4-2 -> 1.5-1) 
Bonjour,

Voici qui est fait:
[2009-02-16 14:45] upgraded xf86-input-evdev (2.1.2-1 -> 2.1.0-1)
[2009-02-16 14:45] upgraded xf86-input-keyboard (1.3.2-1 -> 1.3.1-1)
[2009-02-16 14:46] upgraded xkeyboard-config (1.5-1 -> 1.4-2)
Faudrait voir le diff du contenu de ces paquetages si possible.
Je vais redémarrer X et revenir dire si le downgrade est réparateur.
Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Message par mélodie »

mélodie a écrit :
marc[i1] a écrit :Faudrait voir le diff du contenu de ces paquetages si possible.
Je vais redémarrer X et revenir dire si le downgrade est réparateur.
Bon apparemment la situation est rétablie. J'ai fait un diff sur ceux-là, mais je ne sais pas ce qu'il faudrait chercher:
xf86-input-evdev-2.1.0-1-i686.pkg.tar.gz
xf86-input-evdev-2.1.2-1-i686.pkg.tar.gz

extrait et renommé les répertoires /usr :

$ diff usr-2.1.0/ usr-2.1.2/
Les sous-répertoires usr-2.1.0/include et usr-2.1.2/include sont identiques.
Les sous-répertoires usr-2.1.0/lib et usr-2.1.2/lib sont identiques.
Les sous-répertoires usr-2.1.0/share et usr-2.1.2/share sont identiques.

Je me propose de laisser ceux qui savent faire les recherches.

Merci, en attendant les prochains reboot éventuellement révélateurs ? (Ça c'est de la distro acrobatique ! J'avais presque oublié comment ça fait une <s>distro</s> *Archlinux* toujours à jour ! :D )

Merci marc[i1].
Dernière modification par mélodie le lun. 16 févr. 2009, 17:35, modifié 1 fois.
annaellevera
Daikyu
Messages : 52
Inscription : ven. 06 juin 2008, 09:19

Message par annaellevera »

pas de methode sans avoir à downgrader?
Image

World will end in 5 minutes. Please log out.
Avatar de l’utilisateur
marc[i1]
Maître du Kyudo
Messages : 1753
Inscription : ven. 27 oct. 2006, 10:48
Localisation : Nantes (44)
Contact :

Message par marc[i1] »

annaellevera a écrit :pas de methode sans avoir à downgrader?
si copier 10-keymap.fdi au bon endroit.

Mais si tu n'utilise pas hal pour la détection du clavier bah ... pas de solution pour le moment.
Ne vous emmerdez plus, emmerdez les autres.
Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Message par mélodie »

marc[i1] a écrit : si copier 10-keymap.fdi au bon endroit.

Mais si tu n'utilise pas hal pour la détection du clavier bah ... pas de solution pour le moment.
En effet, pour ma part je ne veux pas utiliser hal : sinon par ailleurs, je n'ai pas la résolution que je veux.

(1024x768 au lieu de 1400x1050 par défaut).
annaellevera
Daikyu
Messages : 52
Inscription : ven. 06 juin 2008, 09:19

Message par annaellevera »

pareil je ne veux pas utiliser hal, par contre je n'ai pas de probleme de resolution.

wait & see alors
Image

World will end in 5 minutes. Please log out.
Avatar de l’utilisateur
wido
Chu Ko Nu
Messages : 497
Inscription : mar. 21 oct. 2008, 20:59

Message par wido »

pour ma part j'ai de nouveau le problème même avec cette modif au login du gdm
Image
Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Message par mélodie »

wido a écrit :pour ma part j'ai de nouveau le problème même avec cette modif au login du gdm
Bonsoir,

C'est tout ce que tu donnes comme information, et que tu poses comme question ?

Je suggère une vérification du contenu du /etc/hal/fdi/policy/10-keymap.fdi, puisque tu sembles utiliser hal et evdev, et un NoUpgrade = /etc/hal/fdi/policy/10-keymap.fdi dans pacman.conf, peut-être calmer les choses.
Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Message par mélodie »

Bonsoir,

Avant de quitter la session je lance une mise à jour pour voir. Les trois paquets que j'ai réinstallés en version inférieure sont bien sûr à nouveau de la partie : donc je les met en IgnorePkg dans mon pacman.conf : les premiers pour lesquels je fais ça pour cette installation.

J'espère que des versions corrigées sortiront : quoi dire et comment faire un bon rapport de bug dans le cas présent ? Y en a-t-il déjà d'écrit ?
Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Message par tuxce »

pour ceux qui ont encore le souci, vous pouvez poster (enfin un seul devrait être suffisant) le /var/log/Xorg.0.log
Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Message par mélodie »

En fqit ;qintenqnt j4qi le ;[e;e souci aue lq;is7re et vinvin . [querty] Suite maj firefox

Pas si facile quand on est habitues a un clavier fr avec accents et tout ?

Pour le Xorg.0.log : http://pastebin.archlinux.fr/314627


Je ;e de<<< uh ?

:evil:

upgrader les paquets que j4ai - elle est ou l apostrophe - ?
:cry:
:arrow:

/Edit 13:39
Test à voir de suite : après avoir relancé Firefox, ces accents sont revenus. (Ces deux sujets se ressemblent-ils, - ou pas - ? )
Répondre