[ENTHOUGHT epd] wxpython 2.8 manquant (résolu)

Applications, problèmes de configuration réseau
Avatar de l’utilisateur
Seym
Hankyu
Messages : 27
Inscription : sam. 09 avr. 2011, 13:14

[ENTHOUGHT epd] wxpython 2.8 manquant (résolu)

Message par Seym » jeu. 21 févr. 2013, 18:41

Bonjour,

J'ai téléchargé et installé epd 32 bits (Enthought, distribution python2.7 pour le calcul scientifique), en exécutant un le .sh fournit de 90mo, le seul paramètre à fournir étant le répertoire d'installation.
Sur mon lubuntu 64 bits, ça marche très bien, mais sur manjaro 32 bits, même si le shell python se lance bien, impossible d'importer pylab : ("/home/seym/.ENTHOUGHT/" est le répertoire d'instalation de epd)

Code : Tout sélectionner

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/home/seym/.apps/epd_rh3/lib/python2.7/site-packages/pylab.py", line 1, in <module>
    from matplotlib.pylab import *
  File "/home/seym/.apps/epd_rh3/lib/python2.7/site-packages/matplotlib/pylab.py", line 221, in <module>
    from matplotlib import mpl  # pulls in most modules
  File "/home/seym/.apps/epd_rh3/lib/python2.7/site-packages/matplotlib/mpl.py", line 1, in <module>
    from matplotlib import artist
  File "/home/seym/.apps/epd_rh3/lib/python2.7/site-packages/matplotlib/artist.py", line 6, in <module>
    from transforms import Bbox, IdentityTransform, TransformedBbox, TransformedPath
  File "/home/seym/.apps/epd_rh3/lib/python2.7/site-packages/matplotlib/transforms.py", line 34, in <module>
    from matplotlib._path import affine_transform
ImportError: libstdc++.so.5: cannot open shared object file: No such file or directory
C'est embêtant de devoir retourner sur lubuntu pour programmer en python.
Je vous remercie d'avance
Dernière modification par Seym le ven. 22 févr. 2013, 23:22, modifié 4 fois.

Avatar de l’utilisateur
Tetsumaki
archer
Messages : 141
Inscription : jeu. 06 mai 2010, 05:44
Contact :

Re: [ENTHOUGHT epd free] bug pylab et idle

Message par Tetsumaki » jeu. 21 févr. 2013, 19:02

Et sur AUR ?
https://aur.archlinux.org/packages/python2-epd-oss/
yaourt -S python2-epd-oss
Ce n'est pas bon ?

Avatar de l’utilisateur
Seym
Hankyu
Messages : 27
Inscription : sam. 09 avr. 2011, 13:14

Re: [ENTHOUGHT epd free] bug pylab et idle

Message par Seym » jeu. 21 févr. 2013, 21:59

Oui c'est vrai, j'avais d'ailleurs oublié que j'avais trouvé cette solution (j'étais en pleine révision et j'ai zappé ensuite), mais une fois installé ça pendra plus d'1go d'espace, et j'aurais aimé comprendre pourquoi le epd installé via le .sh téléchargé sur le site de enthought ne fonctionne pas.

Merci pour cette solution, j'opterai pour celle-là si personne si personne n'en voit pour le .sh .

EDIT : la raison principale est en fait dans mon post suivant
Dernière modification par Seym le ven. 22 févr. 2013, 12:21, modifié 1 fois.

Avatar de l’utilisateur
Seym
Hankyu
Messages : 27
Inscription : sam. 09 avr. 2011, 13:14

Re: [ENTHOUGHT epd] bug pylab et idle

Message par Seym » ven. 22 févr. 2013, 12:20

En fait c'est pas epd free que je doit installer mais le vrai epd grâce à ma License académique (j'ai édité mes posts en conséquence), car elle est plus performante, notamment parce qu'elle utilise mkl, technologie propriétaire d'intel qui rend python aussi voir plus rapide que matlab.

epd-oss n'est donc pas une solution pour moi, car elle ne contient pas mkl.

Des utilisateurs de epd auraient-ils une solution.

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10531
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [ENTHOUGHT epd] bug pylab et idle

Message par FoolEcho » ven. 22 févr. 2013, 18:28

Salut,

Je ne suis pas utilisateur d'epd, par contre:
Seym a écrit :ImportError: libstdc++.so.5: cannot open shared object file: No such file or directory
Par conséquent, essaie après installation de libstdc++5 (sous 64 bits: lib32-libstdc++5).
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
Seym
Hankyu
Messages : 27
Inscription : sam. 09 avr. 2011, 13:14

Re: [ENTHOUGHT epd] bug pylab et idle

Message par Seym » ven. 22 févr. 2013, 23:05

Oui en effet il fallait installer libstdc++.so.5, je m'en suis rendu compte après, mais par la suite il réside toujours un problème, il ne semble pas trouver wxpython :
File "<stdin>", line 1, in <module>
File "/home/seym/.apps/epd/lib/python2.7/site-packages/pylab.py", line 1, in <module>
from matplotlib.pylab import *
File "/home/seym/.apps/epd/lib/python2.7/site-packages/matplotlib/pylab.py", line 264, in <module>
from matplotlib.pyplot import *
File "/home/seym/.apps/epd/lib/python2.7/site-packages/matplotlib/pyplot.py", line 95, in <module>
new_figure_manager, draw_if_interactive, _show = pylab_setup()
File "/home/seym/.apps/epd/lib/python2.7/site-packages/matplotlib/backends/__init__.py", line 25, in pylab_setup
globals(),locals(),[backend_name])
File "/home/seym/.apps/epd/lib/python2.7/site-packages/matplotlib/backends/backend_wxagg.py", line 23, in <module>
import backend_wx # already uses wxversion.ensureMinimal('2.8')
File "/home/seym/.apps/epd/lib/python2.7/site-packages/matplotlib/backends/backend_wx.py", line 65, in <module>
raise ImportError(missingwx)
ImportError: Matplotlib backend_wx and backend_wxagg require wxPython >=2.8
Pourtant dans le répertoire d'installation de epd, il y a bien include/wx-2.8/wx/

J'ai quand même installé wxpython2.8 via pacman au cas ou, mais rien n'y change.

EDIT : En essayant d'importer wx tout seul, il m'a dit qu'il me manquait libjpeg.so.62. J'ai donc installé libjpeg6 sur AUR et ça marche!

Répondre