[ldconfig] Problème avec pacman (résolu)

Mise à jour / Création /debug de paquetages
Répondre
Avatar de l’utilisateur
polo03
Hankyu
Messages : 13
Inscription : lun. 25 févr. 2013, 16:19
Localisation : France, Europe, Monde, Univers.

[ldconfig] Problème avec pacman (résolu)

Message par polo03 » sam. 29 juin 2013, 16:04

Bonjour,

Voilà, mon pc mysterieusement rebooté lors de l'installation d'un paquet (pidgin) et j'ai du tout renettoyer à la main pour pouvoir le réinstaller correctement ... --'

Mais maintenant (avant de nettoyer aussi, là n'est pas le problème) à chaque installation/désinstallation de paquets, j'ai ceci à la fin :

Code : Tout sélectionner

ldconfig: Fichier /usr/lib/libmpeg2encpp-2.0.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3_threads.so.3.3.2 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3_threads.so.3 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libcdaudio.so.1 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3_threads.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmpeg2encpp-2.0.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libSoundTouch.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstcodecparsers-0.10.so.23.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3f_threads.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libofa.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstcodecparsers-0.10.so.23 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstphotography-0.10.so.23.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libpurple.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavjpeg.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libSoundTouch.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavrec.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavplay-2.0.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstsignalprocessor-0.10.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libWildMidi.so.1 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstbasecamerabinsrc-0.10.so.23.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmjpegutils-2.0.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libpurple-client.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libWildMidi.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavjpeg-2.0.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavplay-2.0.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libcdaudio.so.1.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libdc1394.so.22.1.8 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3f_threads.so.3 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3.so.3 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3l.so.3.3.2 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmusicbrainz.so.4 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmjpegutils-2.0.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavrec-2.0.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3f.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3f_threads.so.3.3.2 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstphotography-0.10.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmusicbrainz.so.4.0.3 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libpurple-client.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavjpeg-2.0.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libcdaudio.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavfile.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblrdf.so.2.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libSoundTouch.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libdc1394.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfarstream-0.1.so.0.0.1 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavrec-2.0.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstbasevideo-0.10.so.23.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfarstream-0.1.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfarstream-0.1.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3.so.3.3.2 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstcodecparsers-0.10.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3l_threads.so.3 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3l.so.3 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3l_threads.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3f.so.3 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgme.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavfile-2.0.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstbasecamerabinsrc-0.10.so.23 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmjpegutils.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblrdf.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstbasevideo-0.10.so.23 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstvdp-0.10.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmplex2-2.0.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavplay.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstvdp-0.10.so.23.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstvdp-0.10.so.23 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libofa.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libofa.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmusicbrainz.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstsignalprocessor-0.10.so.23 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmplex2.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3l_threads.so.3.3.2 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libWildMidi.so.1.1.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libpurple.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgme.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstsignalprocessor-0.10.so.23.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libpurple.so.0.10.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblrdf.so.2 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstbasevideo-0.10.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3f.so.3.3.2 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavfile-2.0.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgme.so.0.6.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmpeg2encpp.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libpurple-client.so.0.10.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstbasecamerabinsrc-0.10.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstphotography-0.10.so.23 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3l.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libdc1394.so.22 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmplex2-2.0.so.0 est vide, n'a pas été vérifié.
Ca ne me m'empêche pas d'installer désinstaller mes paquets comme je l'entend, mais j'aimerai bien résoudre le problème :)

D'après ce que j'ai pu trouver sur internet, ça viendrait de mon systeme en Ext4 qui a pas bien supporté la coupure du pc pendant l'installation de pidgin. et certains auraient résolu ce problème avec la commande

Code : Tout sélectionner

pacman -Syyf <lepaquetquifaitchierici>
mais cette dernière n'existe manifestement plus ... :(

En vous remerciant d'avance.
Dernière modification par polo03 le dim. 30 juin 2013, 00:35, modifié 1 fois.

benjarobin
Maître du Kyudo
Messages : 15392
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [ldconfig] Problème avec pacman

Message par benjarobin » sam. 29 juin 2013, 17:40

polo03 a écrit :...mais cette dernière n'existe manifestement plus
Toute ton analyse est bonne, cette commande existe bien (ou presque), et c'est bien celle-ci qui doit être exécuté, sauf que l'option force à été renommée...
Tu dois réinstaller tous les paquets qui ont été concerné par la mise à jour. Pour ceci voir le log de pacman (/var/log/pacman) et aide toi de la date en début de ligne...
Par exemple si tu vois une ligne indiquant

Code : Tout sélectionner

upgraded cups-filters (1.0.34-4 -> 1.0.35-1)
ou

Code : Tout sélectionner

installed openresolv (3.5.5-1)
Tu dois réinstaller ces paquets avec cette commande :

Code : Tout sélectionner

pacman -Syy --force openresolv cups-filters
Petite astuce pour gagner du temps (Récupère les paquets installés ou mise à jour à une certaine date) :

Code : Tout sélectionner

# Modifier la date...
grep -E "\[2013-06-29 [0-9]{2}:[0-9]{2}\]" /var/log/pacman.log | grep -oE "(upgraded|installed) [a-zA-Z0-9_-]+ " | sed -r "s/(upgraded|installed) //"
Donc en une seule ligne

Code : Tout sélectionner

pacman -Syy --force $(grep -E "\[2013-06-29 [0-9]{2}:[0-9]{2}\]" /var/log/pacman.log | grep -oE "(upgraded|installed) [a-zA-Z0-9_-]+ " | sed -r "s/(upgraded|installed) //")
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
polo03
Hankyu
Messages : 13
Inscription : lun. 25 févr. 2013, 16:19
Localisation : France, Europe, Monde, Univers.

Re: [ldconfig] Problème avec pacman

Message par polo03 » sam. 29 juin 2013, 19:00

Merci pour ta réponse, donc n'ayant plus vraiment en tête la date où ça m'a posé problème j'ai pris une fourchette (jnon non, pas le truc avec les pics... :mrgreen: ) et donc j'ai fait comme ça :

Code : Tout sélectionner

pacman -Syy --force $(grep -E "\[2013-06-2[5-9] [0-9]{2}:[0-9]{2}\]" /var/log/pacman.log | grep -oE "(upgraded|installed) [a-zA-Z0-9_-]+ " | sed -r "s/(upgraded|installed) //")
Je sais pas si "c'est mal" mais ça me praissait plus simple...

Maintenant, voilà ce qu'elle me renvoie :

Code : Tout sélectionner

:: Synchronisation des bases de données de paquets...
 core                                     102,8 KiB   166K/s 00:01 [####################################] 100%
 extra                                   1506,0 KiB   461K/s 00:03 [####################################] 100%
 community                               1959,3 KiB   516K/s 00:04 [####################################] 100%
 multilib                                 106,1 KiB   170K/s 00:01 [####################################] 100%
 archlinuxfr                               14,3 KiB   398K/s 00:00 [####################################] 100%
avertissement : automake-1.14-1 est à jour -- réinstalle
avertissement : cronie-1.4.9-5 est à jour -- réinstalle
avertissement : e2fsprogs-1.42.8-1 est à jour -- réinstalle
avertissement : firefox-22.0-1 est à jour -- réinstalle
avertissement : freetype2-2.5.0.1-1 est à jour -- réinstalle
avertissement : gimp-2.8.6-1 est à jour -- réinstalle
avertissement : grub-2.00.5043-2 est à jour -- réinstalle
avertissement : isl-0.12-1 est à jour -- réinstalle
avertissement : lib32-e2fsprogs-1.42.8-1 est à jour -- réinstalle
avertissement : lib32-glib2-2.36.3-2 est à jour -- réinstalle
avertissement : lib32-libjpeg-turbo-1.3.0-3 est à jour -- réinstalle
avertissement : lib32-gdk-pixbuf2-2.28.2-1 est à jour -- réinstalle
avertissement : libxi-1.7.1-3 est à jour -- réinstalle
avertissement : lib32-libxi-1.7.1-3 est à jour -- réinstalle
avertissement : libxv-1.0.9-1 est à jour -- réinstalle
avertissement : lib32-libxv-1.0.9-1 est à jour -- réinstalle
avertissement : mesa-9.1.3-2 est à jour -- réinstalle
avertissement : lib32-mesa-9.1.3-3 est à jour -- réinstalle
avertissement : lib32-mesa-libgl-9.1.3-3 est à jour -- réinstalle
avertissement : libquvi-scripts-0.4.16-1 est à jour -- réinstalle
avertissement : linux-3.9.8-1 est à jour -- réinstalle
avertissement : linux-headers-3.9.8-1 est à jour -- réinstalle
avertissement : lirc-utils-1:0.9.0-49 est à jour -- réinstalle
avertissement : mesa-libgl-9.1.3-2 est à jour -- réinstalle
avertissement : nouveau-dri-9.1.3-2 est à jour -- réinstalle
erreur : impossible de trouver la cible : as
avertissement : ppp-2.4.5-8 est à jour -- réinstalle
avertissement : procps-ng-3.3.8-2 est à jour -- réinstalle
avertissement : qtchooser-31-1 est à jour -- réinstalle
avertissement : skype-4.2.0.11-3 est à jour -- réinstalle
avertissement : taglib-sharp-2.1.0.0-1 est à jour -- réinstalle
avertissement : thunderbird-17.0.7-1 est à jour -- réinstalle
avertissement : virtualbox-host-dkms-4.2.14-1 est à jour -- réinstalle
avertissement : virtualbox-host-modules-4.2.14-2 est à jour -- réinstalle
avertissement : virtualbox-4.2.14-1 est à jour -- réinstalle
avertissement : wine-1.6rc4-1 est à jour -- réinstalle
avertissement : winetricks-20130624-1 est à jour -- réinstalle
avertissement : xorg-server-common-1.14.2-1 est à jour -- réinstalle
avertissement : xorg-server-1.14.2-1 est à jour -- réinstalle
avertissement : lib32-freetype2-2.5.0.1-1 est à jour -- réinstalle
erreur : impossible de trouver la cible : as
avertissement : pacman-mirrorlist-20130626-1 est à jour -- réinstalle
avertissement : k3b-2.0.2-8 est à jour -- réinstalle
erreur : impossible de trouver la cible : tor-browser-en
avertissement : openvpn-2.3.2-1 est à jour -- réinstalle
avertissement : colord-1.0.1-1 est à jour -- réinstalle
avertissement : cups-filters-1.0.35-1 est à jour -- réinstalle
avertissement : curl-7.31.0-1 est à jour -- réinstalle
avertissement : omission de la cible : grub
avertissement : gtkmm-2.24.4-1 est à jour -- réinstalle
avertissement : imagemagick-6.8.6.2-1 est à jour -- réinstalle
avertissement : libva-1.2.1-1 est à jour -- réinstalle
avertissement : libwebp-0.3.1-1 est à jour -- réinstalle
avertissement : omission de la cible : linux
avertissement : omission de la cible : linux-headers
avertissement : omission de la cible : lirc-utils
avertissement : man-db-2.6.5-1 est à jour -- réinstalle
avertissement : ntfs-3g-2013.1.13-4 est à jour -- réinstalle
avertissement : omission de la cible : virtualbox-host-modules
avertissement : omission de la cible : wine
avertissement : wireshark-cli-1.10.0-3 est à jour -- réinstalle
avertissement : wireshark-gtk-1.10.0-3 est à jour -- réinstalle
avertissement : omission de la cible : openvpn
avertissement : omission de la cible : openvpn
avertissement : omission de la cible : pidgin
avertissement : omission de la cible : pidgin
Y'a plusieurs "omission de cible" et j'ai repéré 2 erreurs :tor-browser-en et as (qui apparait 2 fois) ; ça fait partie à chaque fois des MAJ qui ont été faites entre temps... Je ne sais pas vraiment comment je dois interprêter ça... :?

benjarobin
Maître du Kyudo
Messages : 15392
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [ldconfig] Problème avec pacman

Message par benjarobin » sam. 29 juin 2013, 20:08

Ceci devrait résoudre le problème

Code : Tout sélectionner

yaourt -Syy --force $(grep -E "\[2013-06-2[5-9] [0-9]{2}:[0-9]{2}\]" /var/log/pacman.log | grep -oE "\[PACMAN\] (upgraded|installed) [a-zA-Z0-9_-]+ " | sed -r "s/\[PACMAN\] (upgraded|installed) //" | sort -u)
C'est un peu lourd comme commande...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
polo03
Hankyu
Messages : 13
Inscription : lun. 25 févr. 2013, 16:19
Localisation : France, Europe, Monde, Univers.

Re: [ldconfig] Problème avec pacman

Message par polo03 » sam. 29 juin 2013, 20:33

C'est un peu lourd comme commande...
Surtout quand on comprends pas... :mrgreen:

Je te fait conficance, mais j'ai un doute sur le fonctionnement de la chose étant donné qu'après avoir tout réinstallé, à la fin de l'éxecution de la commande, il m'a ressortit ça :

Code : Tout sélectionner

ldconfig: Fichier /usr/lib/libmpeg2encpp-2.0.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3_threads.so.3.3.2 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3_threads.so.3 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libcdaudio.so.1 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3_threads.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmpeg2encpp-2.0.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libSoundTouch.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstcodecparsers-0.10.so.23.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3f_threads.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libofa.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstcodecparsers-0.10.so.23 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstphotography-0.10.so.23.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libpurple.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavjpeg.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libSoundTouch.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavrec.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavplay-2.0.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstsignalprocessor-0.10.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libWildMidi.so.1 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstbasecamerabinsrc-0.10.so.23.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmjpegutils-2.0.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libpurple-client.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libWildMidi.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavjpeg-2.0.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavplay-2.0.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libcdaudio.so.1.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libdc1394.so.22.1.8 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3f_threads.so.3 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3.so.3 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3l.so.3.3.2 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmusicbrainz.so.4 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmjpegutils-2.0.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavrec-2.0.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3f.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3f_threads.so.3.3.2 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstphotography-0.10.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmusicbrainz.so.4.0.3 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libpurple-client.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavjpeg-2.0.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libcdaudio.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavfile.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblrdf.so.2.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libSoundTouch.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libdc1394.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfarstream-0.1.so.0.0.1 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavrec-2.0.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstbasevideo-0.10.so.23.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfarstream-0.1.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfarstream-0.1.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3.so.3.3.2 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstcodecparsers-0.10.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3l_threads.so.3 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3l.so.3 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3l_threads.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3f.so.3 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgme.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavfile-2.0.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstbasecamerabinsrc-0.10.so.23 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmjpegutils.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblrdf.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstbasevideo-0.10.so.23 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstvdp-0.10.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmplex2-2.0.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavplay.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstvdp-0.10.so.23.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstvdp-0.10.so.23 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libofa.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libofa.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmusicbrainz.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstsignalprocessor-0.10.so.23 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmplex2.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3l_threads.so.3.3.2 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libWildMidi.so.1.1.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libpurple.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgme.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstsignalprocessor-0.10.so.23.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libpurple.so.0.10.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblrdf.so.2 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstbasevideo-0.10.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3f.so.3.3.2 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/liblavfile-2.0.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgme.so.0.6.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmpeg2encpp.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libpurple-client.so.0.10.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstbasecamerabinsrc-0.10.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libgstphotography-0.10.so.23 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libfftw3l.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libdc1394.so.22 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libmplex2-2.0.so.0 est vide, n'a pas été vérifié.
:|

benjarobin
Maître du Kyudo
Messages : 15392
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [ldconfig] Problème avec pacman

Message par benjarobin » sam. 29 juin 2013, 20:48

Tu es sûr de la période ?
Peux tu donner la sortie de

Code : Tout sélectionner

grep -E "(mjpegtools|libcdaudio)" /var/log/pacman.log | tail -20
C'est assez étrange... Sinon, il suffira de réinstaller l'ensemble des paquets du système...

Code : Tout sélectionner

pacman -S --force $(comm -13 <(pacman -Qqm | sort -u) <(pacman -Qq | sort -u))
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
polo03
Hankyu
Messages : 13
Inscription : lun. 25 févr. 2013, 16:19
Localisation : France, Europe, Monde, Univers.

Re: [ldconfig] Problème avec pacman

Message par polo03 » sam. 29 juin 2013, 21:46

Tu es sûr de la période ?
Oui. Mais comme tu m'as mis le doute, j'ai refait un essai de la même commande, mais cette fois du 20 au 29, et, après la réinstallation de 600 paquets, j'ai eu la même mauvaise surprise qu'en executant la commande du 25 au 29... -_-
benjarobin a écrit :Peux tu donner la sortie de

Code : Tout sélectionner

grep -E "(mjpegtools|libcdaudio)" /var/log/pacman.log | tail -20
Pas de problèmes, mais je suis pas sûr que le résultat soit très intéressant :

Code : Tout sélectionner

[2013-06-29 21:18] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libcdaudio.so.1.0.0 est vide, n'a pas été vérifié.
[2013-06-29 21:18] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libcdaudio.so est vide, n'a pas été vérifié.
[2013-06-29 21:19] [ALPM-SCRIPTLET] sbin/ldconfig: Fichier /usr/lib/libcdaudio.so.1 est vide, n'a pas été vérifié.
[2013-06-29 21:19] [ALPM-SCRIPTLET] sbin/ldconfig: Fichier /usr/lib/libcdaudio.so.1.0.0 est vide, n'a pas été vérifié.
[2013-06-29 21:19] [ALPM-SCRIPTLET] sbin/ldconfig: Fichier /usr/lib/libcdaudio.so est vide, n'a pas été vérifié.
[2013-06-29 21:22] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libcdaudio.so.1 est vide, n'a pas été vérifié.
[2013-06-29 21:22] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libcdaudio.so.1.0.0 est vide, n'a pas été vérifié.
[2013-06-29 21:22] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libcdaudio.so est vide, n'a pas été vérifié.
[2013-06-29 21:22] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libcdaudio.so.1 est vide, n'a pas été vérifié.
[2013-06-29 21:22] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libcdaudio.so.1.0.0 est vide, n'a pas été vérifié.
[2013-06-29 21:22] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libcdaudio.so est vide, n'a pas été vérifié.
[2013-06-29 21:29] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libcdaudio.so.1 est vide, n'a pas été vérifié.
[2013-06-29 21:29] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libcdaudio.so.1.0.0 est vide, n'a pas été vérifié.
[2013-06-29 21:29] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libcdaudio.so est vide, n'a pas été vérifié.
[2013-06-29 21:38] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libcdaudio.so.1 est vide, n'a pas été vérifié.
[2013-06-29 21:38] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libcdaudio.so.1.0.0 est vide, n'a pas été vérifié.
[2013-06-29 21:38] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libcdaudio.so est vide, n'a pas été vérifié.
[2013-06-29 21:39] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libcdaudio.so.1 est vide, n'a pas été vérifié.
[2013-06-29 21:39] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libcdaudio.so.1.0.0 est vide, n'a pas été vérifié.
[2013-06-29 21:39] [ALPM-SCRIPTLET] ldconfig: Fichier /usr/lib/libcdaudio.so est vide, n'a pas été vérifié.
C'est assez étrange... Sinon, il suffira de réinstaller l'ensemble des paquets du système...
Heu oui ... j'aimerai éviter quand même :')
Mais si vraiment j'en ai besoin, y'aurait pas une option dans yaourt permettant de lancer l'install sans rien me demander (genre est-ce que je veux editer le fichier d'install du paquet machin, ou autre trucs du mêem genre) histoire que je lance ça cette nuit et que je puisse laisser tourner ça tout seul ?

benjarobin
Maître du Kyudo
Messages : 15392
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [ldconfig] Problème avec pacman

Message par benjarobin » sam. 29 juin 2013, 23:41

La dernière commande ne réinstalle que les paquets des dépôts (pas de AUR) donc tu peux le lancer, cela tournera toute la nuit...
Tu peux ajouter l'option --noconfirm, mais ce n'est pas forcément une bonne idée, le plus long sera le téléchargement des paquets...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
polo03
Hankyu
Messages : 13
Inscription : lun. 25 févr. 2013, 16:19
Localisation : France, Europe, Monde, Univers.

Re: [ldconfig] Problème avec pacman

Message par polo03 » dim. 30 juin 2013, 00:34

Bon en fait ça a pris moins de temps que prévu, et ça a fonctionné, ce problème est donc résolu.
Merci à toi :)

Avatar de l’utilisateur
Bismut
Chu Ko Nu
Messages : 343
Inscription : mar. 21 juil. 2009, 09:33
Localisation : Aix-en-Provence

Re: [ldconfig] Problème avec pacman (résolu)

Message par Bismut » mer. 05 oct. 2016, 23:24

Désolé de déterrer ce vieux topic mais j'ai le même problème après une MAJ cauchemardesque (cf. topic voisin).
J'ai bien tenté un :

Code : Tout sélectionner

pacman -Syy --force $(grep -E "\[2016-10-05 [0-9]{2}:[0-9]{2}\]" /var/log/pacman.log | grep -oE "(upgraded|installed) [a-zA-Z0-9_-]+ " | sed -r "s/(upgraded|installed) //")
Cela m'a réinstallé tous les paquets du jour il me semble... Mais, les messages continuent de s'afficher :

Code : Tout sélectionner

ldconfig: Fichier /usr/lib/libQt5Quick.so.5.7.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtDesignerComponents.so.4 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtSql.so.4.8.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtDesigner.so.4.8.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtGui.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt3Support.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtDBus.so.4.8.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtXmlPatterns.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtScript.so.4 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtCLucene.so.4.8 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5QuickWidgets.so.5.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtHelp.so.4.8.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtOpenGL.so.4 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtCLucene.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtXmlPatterns.so.4.8 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt3Support.so.4 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5QuickTest.so.5.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtDBus.so.4.8 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtDBus.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtScriptTools.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtMultimedia.so.4 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtScript.so.4.8 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtScriptTools.so.4.8 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5QuickParticles.so.5.7.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt3Support.so.4.8.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtScript.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5QuickParticles.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtGui.so.4.8.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtDeclarative.so.4.8.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtScriptTools.so.4 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtOpenGL.so.4.8 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtHelp.so.4.8 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtSvg.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtMultimedia.so.4.8 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtHelp.so.4 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtGui.so.4 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt3Support.so.4.8 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtDesigner.so.4.8 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtDesigner.so.4 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5QuickTest.so.5 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5QuickParticles.so.5 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtCLucene.so.4.8.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5QuickTest.so.5.7.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5Quick.so.5 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtTest.so.4.8.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtDesignerComponents.so.4.8 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5QuickWidgets.so.5.7.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtSql.so.4 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtTest.so.4 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtCLucene.so.4 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtScriptTools.so.4.8.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5Quick.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5QuickWidgets.so.5 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtDesignerComponents.so.4.8.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5Qml.so.5 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtXmlPatterns.so.4.8.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5QuickParticles.so.5.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtDesignerComponents.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtDeclarative.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5QuickTest.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5Qml.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtScript.so.4.8.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5QuickWidgets.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5Qml.so.5.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtOpenGL.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtTest.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5Qml.so.5.7.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtSql.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtSvg.so.4.8.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtMultimedia.so.4.8.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtGui.so.4.8 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtDBus.so.4 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtMultimedia.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtSvg.so.4.8 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtDesigner.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQt5Quick.so.5.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtHelp.so est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtTest.so.4.8 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtOpenGL.so.4.8.7 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtXmlPatterns.so.4 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtSql.so.4.8 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtSvg.so.4 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtDeclarative.so.4 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libQtDeclarative.so.4.8 est vide, n'a pas été vérifié.
Comme tout cela concerne Qt et que je ne crois plus utiliser de programmes Qt depuis un bail, j'ai essayé de supprimer peu à peu tous les paquets Qt5... Mais les messages restent... à chaque installation ou désinstallation de paquet.
Ce n'est pas problématique, mais c'est pas très beau de voir toujours tout ça.

J'hésite à lancer la grosse commande qui réinstalle tous les paquets pacman -S --force $(comm -13 <(pacman -Qqm | sort -u) <(pacman -Qq | sort -u)) (6 Go à télécharger pour ma part) par peur de casser mon arch...

Est-ce que je le fais quand même ?
Mac Mini 2011 (SSD) avec Archlinux
Mac Mini 2009 (SSD) avec Archlinux
Asus EeePC S101 avec Archlinux
Zotac Mag et HP College avec Archlinux
Nexus S et Nexus 5 avec Android
Mac Book Air 2013 (SSD) avec OS X Yosemite (Désolé XD)

benjarobin
Maître du Kyudo
Messages : 15392
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [ldconfig] Problème avec pacman (résolu)

Message par benjarobin » mer. 05 oct. 2016, 23:33

Pour ces messages précisément tu peux juste faire ceci :

Code : Tout sélectionner

pacman -S qt4 qt5-declarative
Sinon maintenant si tu veux réinstaller tous les paquets, la commande est plus simple (nouvelle option de pacman) :

Code : Tout sélectionner

pacman -S $(pacman -Qqn)
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Bismut
Chu Ko Nu
Messages : 343
Inscription : mar. 21 juil. 2009, 09:33
Localisation : Aix-en-Provence

Re: [ldconfig] Problème avec pacman (résolu)

Message par Bismut » jeu. 06 oct. 2016, 06:10

Bonjour, et encore désolé de te déranger... Moi qui ne fait que lire en général le forum, je le monopolise décidemment ce soir.

Code : Tout sélectionner

# pacman -S qt4 qt5-declarative
avertissement : qt4-4.8.7-10 est à jour -- réinstalle
résolution des dépendances...
recherche des conflits entre paquets...

Paquets (2) qt4-4.8.7-10  qt5-declarative-5.7.0-3

Taille totale installée :  101,41 MiB

:: Procéder à l’installation ? [O/n] o
(2/2) vérification des clés dans le trousseau      [######################] 100%
(2/2) vérification de l’intégrité des paquets      [######################] 100%
(2/2) chargement des fichiers des paquets          [######################] 100%
(2/2) analyse des conflits entre fichiers          [######################] 100%
erreur : la validation de la transaction a échoué (conflit de fichiers)
qt4 : /usr/bin/assistant-qt4 est déjà présent dans le système de fichiers
qt4 : /usr/bin/designer-qt4 est déjà présent dans le système de fichiers
qt4 : /usr/bin/lconvert-qt4 est déjà présent dans le système de fichiers
qt4 : /usr/bin/linguist-qt4 est déjà présent dans le système de fichiers
qt4 : /usr/bin/lrelease-qt4 est déjà présent dans le système de fichiers
qt4 : /usr/bin/lupdate-qt4 est déjà présent dans le système de fichiers
qt4 : /usr/bin/moc-qt4 est déjà présent dans le système de fichiers
...
...
Au moins 10 000 lignes de qt4 ou de qt5-declarative derrière... (pourtant, j'ai bien désinstallé qt5-declarative hier il me semble... un coup de yaourt me le montre comme non installé)

Faut que je force la réinstallation, un truc du genre ?
Mac Mini 2011 (SSD) avec Archlinux
Mac Mini 2009 (SSD) avec Archlinux
Asus EeePC S101 avec Archlinux
Zotac Mag et HP College avec Archlinux
Nexus S et Nexus 5 avec Android
Mac Book Air 2013 (SSD) avec OS X Yosemite (Désolé XD)

benjarobin
Maître du Kyudo
Messages : 15392
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [ldconfig] Problème avec pacman (résolu)

Message par benjarobin » jeu. 06 oct. 2016, 08:41

Oui
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Bismut
Chu Ko Nu
Messages : 343
Inscription : mar. 21 juil. 2009, 09:33
Localisation : Aix-en-Provence

Re: [ldconfig] Problème avec pacman (résolu)

Message par Bismut » jeu. 06 oct. 2016, 18:08

Super, tout fonctionne à nouveau correctement.

Merci bien. :chinois:
Mac Mini 2011 (SSD) avec Archlinux
Mac Mini 2009 (SSD) avec Archlinux
Asus EeePC S101 avec Archlinux
Zotac Mag et HP College avec Archlinux
Nexus S et Nexus 5 avec Android
Mac Book Air 2013 (SSD) avec OS X Yosemite (Désolé XD)

Répondre