[yaourt] recherche interactive [resolu]

Annonces, dépannage, évolution du projet yaourt
ducamps
Daikyu
Messages : 55
Inscription : mer. 05 nov. 2014, 21:20

[yaourt] recherche interactive [resolu]

Message par ducamps » jeu. 12 févr. 2015, 19:21

bonjour avant aujourd'hui quand j'utilise un yaourt -Sy motclé il me faisait automatiquement une recherche interactive et je n'avais qu'a mettre le numéro de package a installer mais depuis aujourd'hui quand je fait cette commande il se comport comme un pacman -Sy standart avez vous déja rencontrer ce probléme
Dernière modification par ducamps le ven. 13 févr. 2015, 21:22, modifié 1 fois.

otacon
Chu Ko Nu
Messages : 466
Inscription : sam. 07 sept. 2013, 19:22
Localisation : Limousin

Re: [yaourt] recherche interactive

Message par otacon » jeu. 12 févr. 2015, 19:58

as tu essayé :

Code : Tout sélectionner

yaourt -a mot_clé
SYNC OPTIONS
-a, --aur
Also search in AUR database. With -u or --sysupgrade, upgrade aur
packages that are out of date. With -Qm, display more info about
foreign package.

bobo
Elfe
Messages : 531
Inscription : mar. 08 avr. 2014, 22:47

Re: [yaourt] recherche interactive

Message par bobo » jeu. 12 févr. 2015, 20:08

Le comportement que tu attends de yaourt est étrange. Normalement il s'agit d'un wrapper de pacman.

Le paquet n'a pas « bougé » depuis le 23 juin.

Code : Tout sélectionner

$ \ls -l yaourt*
-rw-r--r-- 1 root root 72204 23 juin   2014 yaourt-1.5-1-any.pkg.tar.xz

$ pacman -Qi yaourt
Nom                   : yaourt
Version               : 1.5-1
Description           : A pacman wrapper with extended features and AUR support
Architecture          : any
URL                   : https://github.com/archlinuxfr/yaourt
Licences              : GPL
Groupes               : --
Fournit               : --
Dépend de             : diffutils  pacman>=4.1  package-query>=1.4  gettext
Dépendances opt.      : aurvote: vote for favorite packages from AUR
                        customizepkg: automatically modify PKGBUILD during install/upgrade
                        rsync: retrieve PKGBUILD from official repositories [installé]
Requis par            : --
Optionnel pour        : --
Est en conflit avec   : --
Remplace              : --
Taille installée : 493,00 KiB
Paqueteur             : tuxce <tuxce.net@gmail.com>
Compilé le            : lun. 23 juin 2014 12:37:58 CEST
Installé le           : lun. 23 juin 2014 19:15:37 CEST
Motif d’installation  : Explicitement installé
Script d’installation : Non
Validé par            : Somme SHA256
Restent quelques hypothèses :
– ta config bash : il me semble qu'elle ne peut pas interférer avec un programme bash éxécuté proprement (sans source))
– une maj' de bash (une micro chance que yaourt utilise un « bashisme » qui aurait pu sauter (qui pense à shellshock ?)) : dernière version du 30 décembre, peu probable sinon tu l'aurais vu avant…
– /etc/yaourtrc ? : si tout est commenté chez toi passe ton chemin
– une maj' de pacman : dernière au 12 janvier, il y a eu aussi cette annonce
– le « mot clé » : c'est con mais tu peux essayé…

Je me demande ce que le yaourt pouvait te proposer comme choix. Voici le comportement de « yaourt -Sy <mot_clef> » chez moi :

Code : Tout sélectionner

$ yaourt -Sy toto
Mot de passe : 
:: Synchronisation des bases de données de paquets...
 core est à jour
 extra est à jour
 community est à jour
 archlinuxfr est à jour
 multilib est à jour
Mot de passe : 
erreur : impossible de trouver la cible : toto

$ yaourt -Sy vim
Mot de passe : 
:: Synchronisation des bases de données de paquets...
 core est à jour
 extra est à jour
 community est à jour
 archlinuxfr est à jour
 multilib est à jour
Mot de passe : 
résolution des dépendances...
recherche des conflits entre paquets...
:: vim et gvim sont en conflit. Supprimer gvim ? [o/N] n
erreur : un conflit de paquets impossible à résoudre a été détecté
erreur : la préparation de la transaction a échoué (conflit de dépendances)
:: vim et gvim sont en conflit
dwm — BÉPO — vim — “more is less !”

ducamps
Daikyu
Messages : 55
Inscription : mer. 05 nov. 2014, 21:20

Re: [yaourt] recherche interactive

Message par ducamps » jeu. 12 févr. 2015, 20:20

avec yaourt -a sa fonctionne bizarre que avant il me faiisait sa par default avec -Sy

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1965
Inscription : jeu. 15 mars 2012, 05:08

Re: [yaourt] recherche interactive

Message par waitnsea » jeu. 12 févr. 2015, 20:22

ducamps a écrit :bonjour avant aujourd'hui quand j'utilise un yaourt -Sy motclé il me faisait automatiquement une recherche interactive et je n'avais qu'a mettre le numéro de package a installer mais depuis aujourd'hui quand je fait cette commande il se comport comme un pacman -Sy standart avez vous déja rencontrer ce probléme
Pour moi

Code : Tout sélectionner

yaourt -Sy motclé
ça installe !
Pour la recherche interactive, c'est :

Code : Tout sélectionner

yaourt  motclé
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

bobo
Elfe
Messages : 531
Inscription : mar. 08 avr. 2014, 22:47

Re: [yaourt] recherche interactive

Message par bobo » jeu. 12 févr. 2015, 21:00

waitnsea a écrit :Pour la recherche interactive, c'est :

Code : Tout sélectionner

yaourt  motclé
Je ne le savais pas ! Merci pour l'info.
dwm — BÉPO — vim — “more is less !”

benjarobin
Maître du Kyudo
Messages : 15396
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [yaourt] recherche interactive

Message par benjarobin » jeu. 12 févr. 2015, 22:15

:resolu: Sinon étrange car personnellement pacman -Sy <mot clé> n'a jamais pu faire de recherche interactive.

De plus il est fortement déconseillé de faire pacman -Sy <nom-du-paquet>.
Il faut faire soit : pacman -S <nom-du-paquet>, soit pacman -Syu <nom-du-paquet>
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Répondre