[matériel] clavier bépo Résolu

Reconnaissance et configuration du matériel / kernel linux
Avatar de l’utilisateur
Usul
Hankyu
Messages : 12
Inscription : dim. 05 nov. 2017, 12:34

[matériel] clavier bépo Résolu

Message par Usul »

Bonjour,

J'utilise un clavier bépo TypeMatrix 2030 USB avec KDE Plasma le tout à jour.
Déjà, au démarrage, j'ai une fenêtre de login, que je n'arrive pas à enlever, et je constate que le clavier n'est pas
en bépo.
De même, lorsque j'arrive sur le bureau, pas de bépo.
J'ai suivi ce qui est dit sur le wiki : https://wiki.archlinux.fr/Dvorak

J'ai inclu cette commande

Code : Tout sélectionner

setxkbmap fr bepo
dans ~/.xinitrc
Sans résultat.

Dans la partie Installation sous Xorg, il y a écrit :

Code : Tout sélectionner

Sinon de manière globale, configurer Xorg comme suit : veuiller éditer le fichier /etc/X11/xorg.conf, repérer la section InputDevice avec Driver "keyboard", mettez XkbLayout "fr" et XkbVariant "bepo" (avec Xorg 1.8, mettre ces informations dans un /etc/X11/xorg.conf.d/20-keymap.conf: 
Alors, déjà, je n'ai pas le même chemin, chez moi c'est

Code : Tout sélectionner

/etc/X11/xorg.conf.d/00-keyboard.conf
Et dans le fichier, je n'ai pas la section « InputDevice » chez moi il y a : Section "InputClass"
Voici ce que contient ce fichier :

Code : Tout sélectionner

Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option "XkbLayout" "fr-bepo"
Option "XkbVariant" "bepo"    #### Cette ligne je l'ai rajouté. Elle n'y était pas au début, mais cela ne change rien, ça ne fonctionne pas.########
EndSection
Voilà. À chaque fois, au démarrage je dois écrire le mot de passe, le copier et le coller.
Puis, une fois arrivé sur le bureau, je dois faire dans le terminal :

Code : Tout sélectionner

setxkbmap fr bepo
C'est assez emmerdant, vraiment.
Y a t-il un moyen de faire que cela fonctionne ?
Si oui, comment ?
Merci pour votre aide.
Dernière modification par Usul le mar. 07 nov. 2017, 20:43, modifié 1 fois.
Ceux qui ne bougent pas ne sentent pas leurs chaines. (Rosa Luxembourg.)
jean_no
yeomen
Messages : 278
Inscription : dim. 09 sept. 2007, 12:19

Re: [matériel] clavier bépo

Message par jean_no »

Salut

Je suppose que tu te sers de sddm pour ouvrir ta session sous KDE; si oui, le fichier ~/.xinitrc n'est pas lu.

Pour avoir un clavier BÉPO fonctionnel avec Plasma 5 (KDE), voici le contenu de mon fichier /etc/X11/xorg.conf.d/10-keyboard-layout.conf:

Code : Tout sélectionner

Section "InputClass"
    Identifier         "Keyboard Layout"
    MatchIsKeyboard    "yes"
    MatchDevicePath    "/dev/input/event*"
    Option             "XkbLayout"  "fr"
    Option             "XkbVariant" "bepo_latin9"
    Option             "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
Ensuite, dans Configuration du Système -> Périphériques d'entrée -> Clavier -> Onglet Disposition, coches Configurer des dispositions et choisis Plan = fr, Disposition = Français, Variante = Français (Bépo ergonomique...), Étiquette = fr

A+
Avatar de l’utilisateur
Usul
Hankyu
Messages : 12
Inscription : dim. 05 nov. 2017, 12:34

Re: [matériel] clavier bépo

Message par Usul »

Merci beaucoup jean_no, cela fonctionne très bien.
Sans ton aide c'était pas évident.
Ceux qui ne bougent pas ne sentent pas leurs chaines. (Rosa Luxembourg.)
Répondre